Results 1 to 4 of 4
  1. #1

    sl 750 Problem help

    Hello everyone, I recently got a 94 sl750. It had a hole in the # 1 piston and need rings for the other 2. I replaced the piston and the rings and changed put the fuel pump so # 1 won't burn up again. Everything went fine putting it all back together but I went to the lake to start it and it started but after I would release the choke it would just start reving really high. It would go to about 40mph without pushing the the throttle. Someone told me it could be a problem with the reeds. I took the reeds out and one was stuck open about 16th of an inch and 1 or 2 of the reeds was kinda worn on each side of each one. Could this have anything to do with the high reving? The carb butterflys seem to be closing I havent looked while it is running though.Thanks in advance for any help.


  2. #2
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,327
    +1
    29
    Sounds like you have an air leak.

    Did you do a leak down test after assembly?

    Did you install the exh manifold before tightening down the cyls?

  3. #3
    I didnt do a leak down test after assembly and I tightened the cylinders first.I did compression check when I got done.

  4. #4
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,327
    +1
    29
    Most likely you ruined a cyl base gasket by not installing (even temporarily) the exh manifold.

    You will most likely ruin a piston if you run it as is.

    Conduct a leak down test to verify that you do have an air leak, and not just a throttle cable hanging up.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Please help 1993 Polaris SL 750 Problems
    By sandylowlead in forum Polaris How To & FAQs
    Replies: 7
    Last Post: 08-26-2010, 10:58 PM
  2. 93' and 94' SL 750 need help!!
    By dubstylguy in forum Polaris Open Discussion
    Replies: 5
    Last Post: 07-22-2008, 01:30 PM
  3. sl 750 need help
    By jlaracuente in forum Polaris PWC Performance
    Replies: 28
    Last Post: 04-02-2008, 08:53 PM
  4. sl 750 problems
    By JetRider05 in forum Polaris How To & FAQs
    Replies: 17
    Last Post: 08-09-2007, 11:57 PM
  5. 1994 Polaris SL 750 problem
    By Playtime in forum Polaris Open Discussion
    Replies: 5
    Last Post: 04-24-2007, 06:49 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •