Results 1 to 7 of 7
  1. #1

    1999 Genesis troubles

    I just got a 1999 Genesis with a sportcraft boat it attaches to it's a pretty cool set up. I just got it last week and so I put new plugs, fresh fuel, and oil in it. I took it out on the water and it will only do about 20 miles an hour pushing the boat(previous owners said it would do 30-35), so I unhooked and took just the jet ski out and as soon as you hit the gas to get moving, no matter how much or how little throttle you use it hits the rev limiter at just over seven grand on the display. It hits the limiter until you are up on a plane then it quits hitting the limiter. The other problem is, we were on smooth water and it only tops out at 30 miles an hour. Seems like these machines are supposed to go around fifty if I remember right. It seems to run pretty well, it does kind of load up a little if you let it idle for a while then try to go, but it clears up pretty quick. So what do you guys think I am up against. This is a 99 Genesis 1200 with triple carbs.


  2. #2
    oh ya and here is this rundown:
    Where u from? Idaho Falls Idaho, pwc came out of Utah
    what kind of ski? Polaris Genesis
    what year? 1999
    what kind of engine? 1200 carburated
    how many hours on the meter? 160
    how long did it sit? Over the winter and part of last summer
    recent tune-ups or rebuild? not that I know of
    general history of the ski if you know? Been in fresh water all it's life in Utah that's about all I know
    comes with trailer? y
    live on water? y
    did the ski run on saltwater or normal lake water. Lake water
    compression numbers? not sure
    does it run? Yes

  3. #3
    Quote Originally Posted by Extremesounds313 View Post
    I just got a 1999 Genesis with a sportcraft boat it attaches to it's a pretty cool set up. I just got it last week and so I put new plugs, fresh fuel, and oil in it. I took it out on the water and it will only do about 20 miles an hour pushing the boat(previous owners said it would do 30-35), so I unhooked and took just the jet ski out and as soon as you hit the gas to get moving, no matter how much or how little throttle you use it hits the rev limiter at just over seven grand on the display. It hits the limiter until you are up on a plane then it quits hitting the limiter. The other problem is, we were on smooth water and it only tops out at 30 miles an hour. Seems like these machines are supposed to go around fifty if I remember right. It seems to run pretty well, it does kind of load up a little if you let it idle for a while then try to go, but it clears up pretty quick. So what do you guys think I am up against. This is a 99 Genesis 1200 with triple carbs.
    Is the impeller slipping? sounds like cavitation to me.

  4. #4
    What's the best way to tell if the impeller is slipping? I did some searching on these forums yesterday before I posted and was wondering if it was cavitation too.

  5. #5
    Quote Originally Posted by Extremesounds313 View Post
    What's the best way to tell if the impeller is slipping? I did some searching on these forums yesterday before I posted and was wondering if it was cavitation too.
    You could look and see if there is alot of wear on the impeller or just take the pump housing off because you also might have a bad driveshaft the splines could be bad on the coupler side.

  6. #6
    With the kind of cavitation you are descriding... you have an air leak. I would be pointing my finger at the driveshaft seal.

  7. #7
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,599
    +1
    1,276
    Start with the basics.

    Remove the jet pump, and verify condition of the jet pump components;
    Stator, impeller, bearings, blade clearance.

    Remove drive shaft and check condition of shaft and through-hull bearing seals.

    Examine rubber bonded coupler for signs of slippage (rubber dust, cracked rubber, slipped inner spline section).

    Examine splines on both ends of drive shaft, and inside impeller and drive coupler. Do NOT stick your finger into there - metal slivers are painful.

    Click below for more

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1999 Genesis engine rebuild (need some tips and help)
    By markdgenesis in forum Polaris Open Discussion
    Replies: 4
    Last Post: 07-17-2009, 04:50 PM
  2. Wanted: 1999 Genesis CDI box new or used
    By Rebcammaz in forum Polaris Classifieds
    Replies: 6
    Last Post: 06-05-2009, 02:24 PM
  3. polaris 1999 Genesys surge problems
    By raygrima in forum Polaris Open Discussion
    Replies: 12
    Last Post: 01-25-2009, 11:32 AM
  4. 2003 Genesis trouble! HELP!!!
    By TXLEARMECH in forum Polaris How To & FAQs
    Replies: 15
    Last Post: 08-01-2008, 08:09 PM
  5. 1999 genesis ficht speedometer not working
    By wmwbutler in forum Polaris Open Discussion
    Replies: 4
    Last Post: 09-04-2007, 12:54 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •