Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 22
  1. #1

    94 sl 650 not pumping fuel

    Hey guys I am working on a 94 650 and the plug was left out of it and it sank. The kid who owns it tried to work on it himself and then brought it by for me to fix. He changed the circuit board. Took the carbs off, put new reeds in, and for some reason put new head gaskets in. I fixed the wiring problem from him changing the board. I fixed the oil pump rod he had on wrong. So I go to start the boat and will run on gas I pour in the carbs but not on its own. I checked all the hoses they are on right. So I run the reserve line to the separator and it pumps fuel fine. I try another fuel valve and it wont run. I tried a third and still nothing. Could the pump be too weak to go through the shutoff? our am I just missing something?


  2. #2
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31
    May have fluid or debris clogging the pulse hose or fitting.

    The fuel pump diaphragm may be damaged or have water rapped behind it.

    Make sure the filters are all clean and clear.

    Check the petcock for obstructions.

    Check the fuel tank pick up lines for damage or clogging.

  3. #3
    Quote Originally Posted by xlint89 View Post
    May have fluid or debris clogging the pulse hose or fitting.

    The fuel pump diaphragm may be damaged or have water rapped behind it.

    Make sure the filters are all clean and clear.

    Check the petcock for obstructions.

    Check the fuel tank pick up lines for damage or clogging.
    Thanks for the reply. I checked the pulse line it is clear. filters are new, Petcock seems clear i can blow through it. pick up lines are ok. I am hoping it is the pump cause I am about out of options

  4. #4
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31
    Quote Originally Posted by zman15 View Post
    Thanks for the reply. I checked the pulse line it is clear. filters are new, Petcock seems clear i can blow through it. pick up lines are ok. I am hoping it is the pump cause I am about out of options
    Petcock seems clear is not a good test. You need to check it out. Just because you can blow through it, doesn't mean you can pull enough fuel through it to feed 3 thirsty carbs. Or if the petcock is leaking air, you can blow through it, but the carbs will not be supplied sufficiently.

    Pick up lines are ok? Did you inspect them, or "blow through them? If you have the old style pick up hoses, they are notorious for falling off. Which you can blow through, but not pick up any fuel.

    You can always open up the fuel pump and inspect it/rebuild it, or just replace it due to age and the fact the ski was sunk and may have stretched the diaphragm weakning it.

  5. #5
    Quote Originally Posted by xlint89 View Post
    Petcock seems clear is not a good test. You need to check it out. Just because you can blow through it, doesn't mean you can pull enough fuel through it to feed 3 thirsty carbs. Or if the petcock is leaking air, you can blow through it, but the carbs will not be supplied sufficiently.

    Pick up lines are ok? Did you inspect them, or "blow through them? If you have the old style pick up hoses, they are notorious for falling off. Which you can blow through, but not pick up any fuel.

    You can always open up the fuel pump and inspect it/rebuild it, or just replace it due to age and the fact the ski was sunk and may have stretched the diaphragm weakning it.
    I took the lines out of the tank and inspected them. I got the pump apart im waiting for a kit to rebuild it. Can you take the petcock apart? How do you test it? Thanks for the help!

  6. #6
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31
    Yes you can.

    Open it up. Make sure the rubber seal isn't swelling shut, or dry rotting and clogging the small opening.

    Lube the O ring and seal with some 2 stroke oil.

    Or just replace the petcock with a new one. (about $15) Polaris discontinued them, so you'll need to get the Sea doo valves now. They work, but the selector positions are slightly different. (no big deal)

    Did you find any water behind the diaphragm in the fuel pump?

    Also, now would be a good time to thoroughly clean/inspect/rebuild the carbs.

    And replace the fuel hoses too if they're original. (about $20) If you do them, make sure to re-install the restrictor inside the return hose. (found about 1" past the carbs INSIDE the return hose)

  7. #7
    I did not find any water behind the diaphragm in the pump. I wonder if the restrictor fell out or is missing when the kid took off the carbs. I thought the 94 had the restrictor in the carbs though?

  8. #8
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31
    Nope.....

    You can try bypassing the petcock for now and see if that helps.

    Also make sure the fuel tank vents are operational. (try leaving the gas cap off when testing next time.

  9. #9
    I did try bypassing the petcock and it did work. I will try the gas cap next. thanks

  10. #10
    Ok so I tried the gas cap and nothing changed. rebuilt the fuel pump still the same. Pumps good without the shut off valve. Wont pump at all with it. Any ideas?

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 94 polaris sl 650 not reving out on top end???
    By LNewman in forum Polaris How To & FAQs
    Replies: 38
    Last Post: 01-18-2010, 12:03 AM
  2. SL 650 / 750 Pump Rebuild Question
    By rob2337 in forum Polaris Open Discussion
    Replies: 5
    Last Post: 04-02-2008, 06:17 PM
  3. 94 SL 650 - hooked up garden hose, now water in cyls?
    By rgextreme1998 in forum Polaris Open Discussion
    Replies: 19
    Last Post: 07-30-2007, 07:23 PM
  4. 94 SL 650 oil sender question.
    By xlint89 in forum Polaris Open Discussion
    Replies: 5
    Last Post: 05-02-2007, 12:01 AM
  5. 94 sl 650 syphon
    By punchtech in forum Polaris How To & FAQs
    Replies: 5
    Last Post: 05-01-2007, 03:34 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •