Results 1 to 6 of 6
  1. #1
    Banned User
    Join Date
    Aug 2007
    Location
    Reading PA
    Posts
    1,670

    1999 GSX RFI hard starting in water

    Hey guys I got a friend that has a 1999 GSX RFI that starts no problem out of the water easy no problem, in the water is a different story though, it bogs and doesnt want to start, u have to pump the gas on and off and run the starter for ever till it starts, i pulled the plugs and they are golden brown like they should be but that was after i ran it on the hose, I am kinda knew to working on the RFI motor but it looks as if there might be to much oil mixing into the cyl as the plugs are very oily even after it was running. Any way to lean out the oil mix or anything with this ski, I am gonna have him exchange his battery as when i hit the starter it goes to 8.2 volts, this is the first RFI motor i have ever worked on and seen are the supposed to be silver or white, and what color pipe is it supposed to have, as this looks like the whole thing was painted, grayish silver even the pipe.

    thanks for any info
    jon


  2. #2
    olds72's Avatar
    Join Date
    Nov 2009
    Location
    Toledo, OH
    Posts
    173
    +1
    1
    on the front of the oil pump are two marks. One on the pump body and the other on the part where the cable goes. They are suppose to lined up. you lean it out by adjusting the marks so it's closer to where the cable hooks in. Adjustments are made at the other end of the cable near throttle body.

  3. #3
    Banned User
    Join Date
    Aug 2007
    Location
    Reading PA
    Posts
    1,670
    so do i have to pull the pump off the cover to check this? like i said i have never really messed with any of these motors, and all my 2 strokes i have always did the pump block off and used premix.

  4. #4
    olds72's Avatar
    Join Date
    Nov 2009
    Location
    Toledo, OH
    Posts
    173
    +1
    1
    Quote Originally Posted by JonnyRXT View Post
    so do i have to pull the pump off the cover to check this? like i said i have never really messed with any of these motors, and all my 2 strokes i have always did the pump block off and used premix.
    no you can't check this with your pump off. It has to connected with the cable in place. You need a mirror and a flashlight. A 10mm short wrench to loosen the lock nut on the cable at the throttle body. It's a very easy adjustment and you will be able to easliy see the marks on the pump. One thing about RFI's, is you have ro run the oil injction system. The fuel injectors are not designed to run oil/gas mix through them.

  5. #5
    Banned User
    Join Date
    Aug 2007
    Location
    Reading PA
    Posts
    1,670
    ok man thanks i am gonna check it out tomorrow and i will let ya know what i find out.

  6. #6
    Banned User
    Join Date
    Aug 2007
    Location
    Reading PA
    Posts
    1,670
    ok besides checking the oil pump what else can i look at guys cause now that its getting the right amount of oil its still hard to start in the water.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2003 sea doo gtx rfi hard start in water?
    By Alexc_538 in forum 2-Stroke Performance
    Replies: 7
    Last Post: 08-05-2016, 07:48 AM
  2. 1999 Seadoo GSX RFI Extremly hard start in water.
    By RightsaidFred in forum 2-Stroke Performance
    Replies: 14
    Last Post: 07-16-2014, 09:01 AM
  3. 1999 GSC RFI hard start in water
    By starbucks in forum 2-Stroke Performance
    Replies: 0
    Last Post: 07-16-2014, 08:56 AM
  4. 99 seadoo gtx rfi wont start in water
    By havinfun in forum 2-Stroke Performance
    Replies: 14
    Last Post: 08-15-2010, 04:24 PM
  5. 96 xp hard start in water.
    By 99wrangler in forum 2-Stroke Performance
    Replies: 4
    Last Post: 07-15-2008, 06:24 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •