Results 1 to 8 of 8
  1. #1
    Ermiller27's Avatar
    Join Date
    Mar 2009
    Location
    Cleveland OH, Geneva NY
    Posts
    47
    +1
    1

    Supercharger Fell Apart Inside Engine

    I have a 2004 rxp with some stage 2 stuff on it and i recently had the supercharger fall apart twice on me already, some reason the sc nut doesnt hold everything in the shaft and has fallen into the engine... why is this happening?


  2. #2
    jekvall's Avatar
    Join Date
    Nov 2007
    Location
    Chillicothe, OH
    Posts
    353
    Are you using LOCTITE on the nut? Threads all OK?



    QUOTE=Ermiller27;1513318]I have a 2004 rxp with some stage 2 stuff on it and i recently had the supercharger fall apart twice on me already, some reason the sc nut doesnt hold everything in the shaft and has fallen into the engine... why is this happening?[/QUOTE]

  3. #3
    Ermiller27's Avatar
    Join Date
    Mar 2009
    Location
    Cleveland OH, Geneva NY
    Posts
    47
    +1
    1
    yes i used locktite and the threads were not damaged

  4. #4
    home of the dislexic fingers breon's Avatar
    Join Date
    Aug 2007
    Location
    port st lucie fl
    Posts
    3,471
    all you can do is clean the threads so therfe is no oil on them and red locktight..and toque to spec...it should stay put ..chargers falling apart is not a normal problem...

  5. #5
    Gone in 3.0 seconds... RXPT400's Avatar
    Join Date
    Nov 2007
    Location
    USA
    Posts
    1,527
    sometimes is not the lock nut the gives up, the supercharger bearings is another weak point when it comes to S/C destruction and lack of oil lubrication...

  6. #6
    Make sure you are tightining it to the correct torque as soon as you put the locktite on. I think that is what happened when mine came apart. I put the locktite on and it set up before I torqued it....doesnt take long for that stuff to set up.

  7. #7
    Orlando Shark's Avatar
    Join Date
    Mar 2009
    Location
    Miami, FL
    Posts
    2,419
    +1
    10
    This happened to a friend of mine. What he found that caused the problem was that his slip was set too high for his charger and somehow that caused it to loosen. He set it to the proper slip and has had no problems since.

  8. #8
    Ermiller27's Avatar
    Join Date
    Mar 2009
    Location
    Cleveland OH, Geneva NY
    Posts
    47
    +1
    1
    Thanks for all the help, i will probably just get a rebuilt kit for it, hope it works

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. wasp apartment inside kawasaki ts lol
    By Seakid in forum Kawasaki Projects
    Replies: 2
    Last Post: 03-22-2013, 10:26 PM
  2. Replies: 5
    Last Post: 10-28-2012, 07:52 PM
  3. supercharger came apart - ?'s
    By T5Racing in forum 4-Tec Performance
    Replies: 4
    Last Post: 06-24-2011, 11:02 AM
  4. Replies: 1
    Last Post: 07-04-2010, 01:31 PM
  5. Oil inside engine compartment - minor "spewing"?
    By gmoeller in forum Yamaha PWC Performance (4-stroke)
    Replies: 35
    Last Post: 06-18-2010, 10:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •