Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
  1. #1

    Please help can't figure out why

    Here is the situation. I run a 04 rxp with stage 2+ runs strong at 78 mph, ill be on glass water and all of a sudden i'll get nasty jumps from the front end and trim is set to middle and i tried adjusting but still doesn't help. it also does it out of the hole 2.. can anyone help me plz thnx.


  2. #2
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,930
    +1
    1,407
    Sounds like you are stuffing the pump.

    Oh Welcome to the Hulk.

  3. #3
    FullTilt429's Avatar
    Join Date
    Jul 2010
    Location
    Pleasanton, CA USA
    Posts
    332
    +1
    6
    Go full speed and just cut the throttle....JUST KIDDING!! Look for a pump pressure relief system with the search.

  4. #4
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    Over stuffing an 04 RXP at 78 mph... very, very unlikely Give us more detail about your set-up.

    Welcome to the Hulk Al

  5. #5
    speedskixp's Avatar
    Join Date
    Feb 2008
    Location
    venice fl.
    Posts
    8,117
    +1
    120
    Quote Originally Posted by BigDaddyRXP View Post
    Over stuffing an 04 RXP at 78 mph... very, very unlikely
    +1. Add a set of riva pro opas bo's or get rid of the wedge if it has one

  6. #6

    Join Date
    Oct 2009
    Location
    miami
    Posts
    715
    i still dont know what is the problem he has

  7. #7
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    Quote Originally Posted by stevorxp007 View Post
    i still dont know what is the problem he has
    That's probably why he started a thread here... cause you have no clue

  8. #8
    Eric Ocman's Avatar
    Join Date
    Aug 2008
    Location
    Cataula, Georgia, United States
    Posts
    4,700
    +1
    77
    Quote Originally Posted by BigDaddyRXP View Post
    That's probably why he started a thread here... cause you have no clue
    lol

  9. #9

    Join Date
    Oct 2009
    Location
    miami
    Posts
    715
    my point is what is hes problem he said it jumps from the front what the hell does that mean lol if its over stuffing it droppes not jump, like i said i still dont know what the problem is

  10. #10
    thanx everyone for gettin back so fast..what i mean it jumps like i was riding over a boats wake .....someone told me before it feels like i was stuffing the pump...what does this mean as well?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Can't figure out what ski this fits, perhaps you guys can help.
    By thetolleyman in forum 2-Stroke Performance
    Replies: 5
    Last Post: 09-25-2012, 10:50 AM
  2. need help figuring out why i cant get fuel to my ski
    By brian.shindler in forum Polaris Open Discussion
    Replies: 1
    Last Post: 07-05-2011, 03:55 PM
  3. Replies: 0
    Last Post: 07-19-2008, 09:18 PM
  4. i can't figure out why?
    By pet in forum 4-Tec Performance
    Replies: 11
    Last Post: 06-01-2007, 05:49 AM
  5. Please Help! Can't remove Large Cotter Pin Karavan Trailer
    By holdnon72 in forum 4-Tec Performance
    Replies: 7
    Last Post: 03-18-2007, 09:28 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •