Results 1 to 4 of 4

Thread: 150 vibration

  1. #1

    150 vibration

    i have a 01 ultra 150 and im getting an intense vibration and rattle that is the worst at 6k rpms. is this a sign of the pump bearings going out or a rock ding in the impeller or maybe the impeller is loose? any help would be great, id like to find out what is wrong before i really wreck something thanks

  2. #2
    Check motor mounts, drive shaft bearing and pump bearing....

    I would start there....

    Are you loosing power at 6k also or just vibration?

  3. #3
    no loss in power, it still runs good just vibrating, it has a new drive shaft bearing but ill check all three anyways, thanks

  4. #4
    should there be any play at all in the impeller or should it just be tight and not move at all?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. ultra 150 vibration
    By lkn ultra in forum Kawasaki Open Discussion
    Replies: 4
    Last Post: 06-13-2008, 11:06 PM
  2. VIBRATION with throttle
    By GOLD1300R in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 04-07-2008, 09:28 AM
  3. Vibration
    By Scott in forum Kawasaki Open Discussion
    Replies: 21
    Last Post: 09-11-2007, 05:28 PM
  4. little vibration
    By rwells173 in forum 4-Tec Performance
    Replies: 10
    Last Post: 07-09-2007, 04:40 PM
  5. Vibration!!!!!!!!
    By xplayer2885 in forum Polaris Open Discussion
    Replies: 16
    Last Post: 06-14-2007, 10:58 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts