Results 1 to 2 of 2
  1. #1

    2003 GTX-SC with Riva Stage 1 performing poorly

    I have two issues with my 2003 GTX-SC that has the Riva Stage 1 kit installed. 1) Top speed is only around 58 mph, 2) Take off is extremely lame, can hardly pull a small skier out of the water - almost as if the prop is slipping. Does anyone have any advice as to what could be causing the problems? Seem like after installing the kit I did not get the benefits of additional speed, but lost take off.


  2. #2
    How is the wear ring? Is it cavitating when accellerating?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2007 gtx with Riva stage 2 losing rpm/top speed...so frustrating
    By Apocalapsi in forum 4-Tec Performance
    Replies: 0
    Last Post: 06-30-2014, 09:21 PM
  2. FS - Parts 2003 gtx sc ecu with 100 ish hrs on it
    By two2curupt in forum Sea Doo Classifieds
    Replies: 0
    Last Post: 02-16-2012, 12:39 AM
  3. FS 2003 GTX SC Stage 1 w/ Trailer $5000 OBO
    By NCNismo32 in forum Sea Doo 4Tec Skis
    Replies: 0
    Last Post: 03-09-2010, 08:59 PM
  4. Where should trim be with riva stage one kit
    By macattack in forum 4-Tec Performance
    Replies: 3
    Last Post: 06-30-2005, 09:46 AM
  5. adding external intercooler to 2003 gtx sc motor
    By rapidacceleration in forum 4-Tec Performance
    Replies: 12
    Last Post: 05-12-2005, 08:17 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •