Results 1 to 2 of 2
  1. #1

    Join Date
    Jun 2008
    Location
    florida
    Posts
    168

    HELP WITH A 2000 STX 900 temp light stays on

    My friend just bought a 2000 stx 900 it was taking in water on saturday when the guy had it out so the guy decided to sell the ski to my friend . so my friend found the problem it was a cracked cooling hose so he fixed the hose and got it started on the flush it starts and idles fine also it pisses fine but wont rev up it when he gives it throttle it just stays like alittle above idle . its like the ski is in limp mode .the temp light is staying on. the head and cylinder and pipe are cool. so what are a few thing he should check first ?


  2. #2
    PEVO's Avatar
    Join Date
    Mar 2009
    Location
    central Tx.
    Posts
    85
    Ck. the electronics box to see if it has water damage(water intrusion)

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Yamaha GP1200R problem with no Spark and water temp light comes on?
    By Quottro in forum Yamaha Open Discussion
    Replies: 6
    Last Post: 07-26-2015, 05:04 AM
  2. help !!!!!!! 2000 STX 900 temp sensor
    By XP537 in forum Kawasaki PWC Performance (2-stroke)
    Replies: 1
    Last Post: 06-05-2012, 12:53 AM
  3. WTB WTB: pump with impeller for 2000 STX 900 with no mods
    By gopats in forum Kawasaki Classifieds
    Replies: 1
    Last Post: 07-09-2011, 03:30 PM
  4. 2000 Virage TX - dash lights stay on
    By Mellis in forum Polaris Open Discussion
    Replies: 3
    Last Post: 06-27-2011, 10:36 PM
  5. Help 2000 stx 900
    By Asmarine in forum Kawasaki How To & FAQs
    Replies: 1
    Last Post: 06-10-2009, 04:35 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •