Results 1 to 4 of 4
  1. #1
    Oldnick oldnick's Avatar
    Join Date
    Aug 2007
    Location
    Forest Hill, MD
    Posts
    145
    +1
    10

    2009 FZS No power slow on take off

    Recently my 2009 FZS seems like it has no top end, and on take off it hesitates when I give it gass, I checked the pump and intake looks good not impeller damage... This ski used to jump out of the water on full throttle now it is slow, any one have any suggestions.

    thanks,
    Nick


  2. #2
    fx160's Avatar
    Join Date
    Nov 2005
    Location
    gold coast australia
    Posts
    2,409
    +1
    193
    super charger cutch gone
    if that is the fault from what i have read on here you will be at 5,500 revs max, instead of 7,000+

    kev

  3. #3
    Oldnick oldnick's Avatar
    Join Date
    Aug 2007
    Location
    Forest Hill, MD
    Posts
    145
    +1
    10
    I am still running 7600 rpm can't get over 50, prop looks good nothing in the intake.
    Hardly any water coming out of the water spout but it is not clogged??? Any thoughts.

  4. #4
    fx160's Avatar
    Join Date
    Nov 2005
    Location
    gold coast australia
    Posts
    2,409
    +1
    193
    if it's running at 7,600 revs the engine is fine so it's something in the drive side of things
    a blockage that you missed, bearings almost seized , prop worn out (i doubt),shaft slipping
    climb under and check the grate and intake tunnel

    kev

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Sputter on take off with 2009 FX SHO
    By jger in forum Yamaha PWC Performance (4-stroke)
    Replies: 10
    Last Post: 08-23-2016, 03:15 PM
  2. will ride plate help power on take off and planing out?
    By Firewalker918 in forum 4-Tec Performance
    Replies: 1
    Last Post: 06-19-2012, 09:12 AM
  3. SLT 780 hesitates on take off
    By paramuir in forum Polaris Open Discussion
    Replies: 1
    Last Post: 07-08-2008, 08:57 AM
  4. Massive Cavation on Take off (Ultra 250x)
    By Scott in forum Kawasaki PWC Performance (4-stroke)
    Replies: 20
    Last Post: 09-06-2007, 08:49 PM
  5. 14 hours, lost 200 rpms, hesitates on take off and bad vibration
    By Chris288 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 11
    Last Post: 08-13-2007, 04:21 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •