Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 36
  1. #1
    GPRXP vspec1's Avatar
    Join Date
    Jun 2009
    Location
    Orlando, Fl.
    Posts
    1,517
    +1
    253

    New best speed for me on my 2008 RXPX 85.4 Happy and sad at the same time !!!

    When to a SMALL local lake (lake underhill) by myself this afternoon to test out the new Riva Rideplate I just installed, along with the bigger valves I installed in the pump shoe.

    It turns great, I like it alot better. I went to do a couple of speed runs, the first one it clicked off an 83.4 but when I let off it felt like I hit something in the water. Well I ran it one more time . I got all the way in the no wake zone and headed accross and it went an impressive 85.4 but the second time I lifted, I lifted too quickly and the ass end of the ski popped up and tried to kill me..... I have never experienced a buck before and don't want to ever again. I was actually shaking when I was loading up the ski...

    I really thought going to new 3/4 valves and hoses It would be fine. I guess with the new Riva Rideplate, pump pressures have also gone up?


  2. #2
    Banned User
    Join Date
    Aug 2009
    Location
    Discovery Bay, CA
    Posts
    3,048
    +1
    336
    ooooweee flyin'!! and if your sig is correct you got quite a few more RPM left to stretch it out if you can figure out that buck problem!! congrats on the number

  3. #3
    Eric Ocman's Avatar
    Join Date
    Aug 2008
    Location
    Cataula, Georgia, United States
    Posts
    4,700
    +1
    77
    Congrats bro. Guess the plate is something for me to look at this winter!

  4. #4
    Having Fun jp1300r's Avatar
    Join Date
    Sep 2005
    Location
    Florida
    Posts
    5,334
    +1
    261
    Quote Originally Posted by vspec1 View Post
    When to a SMALL local lake (lake underhill) by myself this afternoon to test out the new Riva Rideplate I just installed, along with the bigger valves I installed in the pump shoe.

    It turns great, I like it alot better. I went to do a couple of speed runs, the first one it clicked off an 83.4 but when I let off it felt like I hit something in the water. Well I ran it one more time . I got all the way in the no wake zone and headed accross and it went an impressive 85.4 but the second time I lifted, I lifted too quickly and the ass end of the ski popped up and tried to kill me..... I have never experienced a buck before and don't want to ever again. I was actually shaking when I was loading up the ski...

    I really thought going to new 3/4 valves and hoses It would be fine. I guess with the new Riva Rideplate, pump pressures have also gone up?
    Sorry, I had to miss your phone call earlier. I was at work in the middle of something. Duke and I are going to try and figure this out. Be careful running that plate. Normal riding, well normal for us LOL, I haven't had a problem.

  5. #5
    GPRXP vspec1's Avatar
    Join Date
    Jun 2009
    Location
    Orlando, Fl.
    Posts
    1,517
    +1
    253
    Thanks guys !!! I really like the Riva rideplate, I got mine the same time as JP1300R. I waited for him to do all the testing before I decided to put it on. I have another prop that Duke did for the summertime, I need to stick it in the ski and see If I can get some RPM back. To tell you the truth, after today's adventure, I'll let one of the other guys ride it for speed. I'm really not into getting hurt anymore, lol

  6. #6
    Eric Ocman's Avatar
    Join Date
    Aug 2008
    Location
    Cataula, Georgia, United States
    Posts
    4,700
    +1
    77
    Quote Originally Posted by vspec1 View Post
    Thanks guys !!! I really like the Riva rideplate, I got mine the same time as JP1300R. I waited for him to do all the testing before I decided to put it on. I have another prop that Duke did for the summertime, I need to stick it in the ski and see If I can get some RPM back. To tell you the truth, after today's adventure, I'll let one of the other guys ride it for speed. I'm really not into getting hurt anymore, lol
    Yep, I will let Jim ride mine first to LOL.

  7. #7
    Banned User
    Join Date
    Aug 2009
    Location
    Discovery Bay, CA
    Posts
    3,048
    +1
    336
    "let those other guys ride it for speed" hahaha i like that idea but man at 85+ i'd say you rode the doo-doo out of it for the time being!

  8. #8
    GPRXP vspec1's Avatar
    Join Date
    Jun 2009
    Location
    Orlando, Fl.
    Posts
    1,517
    +1
    253
    Quote Originally Posted by Ocman View Post
    Congrats bro. Guess the plate is something for me to look at this winter!
    Yes, I think you will really like the plate. It's worth an easy 2-3mph .... I really like the way it turns, it doesn't slide like it used to....

  9. #9
    GPRXP vspec1's Avatar
    Join Date
    Jun 2009
    Location
    Orlando, Fl.
    Posts
    1,517
    +1
    253
    Quote Originally Posted by Mike H View Post
    "let those other guys ride it for speed" hahaha i like that idea but man at 85+ i'd say you rode the doo-doo out of it for the time being!
    Mike, its sad to say at 43 Im turning into a real wuss.

  10. #10
    GPRXP vspec1's Avatar
    Join Date
    Jun 2009
    Location
    Orlando, Fl.
    Posts
    1,517
    +1
    253
    Quote Originally Posted by jp1300r View Post
    Sorry, I had to miss your phone call earlier. I was at work in the middle of something. Duke and I are going to try and figure this out. Be careful running that plate. Normal riding, well normal for us LOL, I haven't had a problem.
    No problem JP, I hope you guys figure it out soon. It's not a good feeling when it happens at that kind of speed.... Are we going to ride anytime soon?

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Orbited and submerged my iS at the same time!
    By UNSANE in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 11-06-2011, 12:00 PM
  2. Replies: 7
    Last Post: 08-11-2010, 05:01 PM
  3. help/question..my r+d powershot is flashing #3 and #8 at the same time
    By MJE in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 08-01-2009, 07:57 PM
  4. new best speed today on my 15f
    By wave15stx in forum Kawasaki PWC Performance (4-stroke)
    Replies: 0
    Last Post: 05-27-2007, 08:41 AM
  5. Any probs in putting all of this on at the same time?
    By Mongoose in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 05-15-2006, 06:59 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •