Results 1 to 7 of 7
  1. #1
    Quinton Robbins's Avatar
    Join Date
    May 2010
    Location
    Jonesboro Ar
    Posts
    728
    +1
    10

    Should I be Worried?

    Is my main relay about to fail?

    Will it leave me stranded?

    While riding today I had something strange happen. I pulled into a cove and stopped the engine. The screen immediately when out rather than remaining on for a moment or so. I pushed the stop button which normally ques the screen but nothing happened. I removed and reinstalled the lanyard, still nothing happened. It was as if the battery has been disconnected. I then removed the seats and checked the battery cables only to find no issues. A few minutes later everything was back to normal and the ski fired right up.

    I also noticed that the clock and other data had all been reset. The ski ran perfectly for the remainder of the day.

    WTH?


  2. #2
    Quinton Robbins's Avatar
    Join Date
    May 2010
    Location
    Jonesboro Ar
    Posts
    728
    +1
    10
    My ski only did this once today. When I first got to the water, I hopped on and clipped in the lanyard. I got a beep-beep and the screen went blank and all power was MIA. I removed the rear seat and jiggled the main power wires and it powered right up. It then worked perfectly for the remainder of the day.

    Still concerned though. I plan to go ahead and order a main relay, but any additional helpful info would be great.

  3. #3
    baba booey's Avatar
    Join Date
    Apr 2007
    Location
    San Diego
    Posts
    526
    it is probably all that WWW.H20XTREME.NET stuff u got on the ski.

  4. #4
    Quinton Robbins's Avatar
    Join Date
    May 2010
    Location
    Jonesboro Ar
    Posts
    728
    +1
    10
    Quote Originally Posted by baba booey View Post
    it is probably all that WWW.H20XTREME.NET stuff u got on the ski.
    Ha Ha. Not likely since I have not touch anything electrical.

  5. #5
    xdrian's Avatar
    Join Date
    Nov 2008
    Location
    Brisbane Australia
    Posts
    898
    +1
    225
    I say you are probley on the right track with relay I would first check clean all battary terminals with a file and then cover with dialectric gresse and same with all terminals on relay once the battary is disconected.
    Also check battary voltage and water level if it is one that you can fill

    Regards Xdrian

  6. #6
    Quinton Robbins's Avatar
    Join Date
    May 2010
    Location
    Jonesboro Ar
    Posts
    728
    +1
    10
    Quote Originally Posted by xdrian View Post
    I say you are probley on the right track with relay I would first check clean all battary terminals with a file and then cover with dialectric gresse and same with all terminals on relay once the battary is disconected.
    Also check battary voltage and water level if it is one that you can fill

    Regards Xdrian
    Will do. I plan to look it over today.

  7. #7
    Quinton Robbins's Avatar
    Join Date
    May 2010
    Location
    Jonesboro Ar
    Posts
    728
    +1
    10
    Well, damn! Im the dork on this one. I made the assumption that since I had never disconnected the battery that surely the cables were both snug. WRONG! When I looked it over today I discovered that the positive battery cable was about two or three turns out from tight.

    Im gonna go ahead and say theres a good chance this was the issue. Ooops.

    Question is could this also have triggered the Oil Light?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Pump Shoe Crack..Should I be worried?
    By kopfb in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 08-03-2011, 04:13 PM
  2. Should I be worried, Impeller Oil
    By Davpmars in forum 2-Stroke Performance
    Replies: 11
    Last Post: 06-24-2010, 03:49 PM
  3. Should I be worried about this....
    By Speed_Freak_039A in forum 4-Tec Performance
    Replies: 0
    Last Post: 10-06-2009, 04:12 PM
  4. Should I be worried or excited?
    By KirkF350 in forum Open Discussion
    Replies: 27
    Last Post: 08-28-2008, 05:27 PM
  5. 1200 SLX, should I be worried part 2
    By bobolie in forum Polaris PWC Performance
    Replies: 16
    Last Post: 09-20-2006, 08:54 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •