Results 1 to 4 of 4

Thread: 2003 msx140 emm

  1. #1

    Join Date
    Jun 2009
    Location
    McAlester, OK
    Posts
    11

    2003 msx140 emm

    I bought two 2003 MSX140 early in 2009 that had 9 hours. yup 9 hrs. I have 71 hours now. I ran about half the summer and now the engine doesn't have any power. It is missing and sometimes I could get up to 40 mph by nursing it. Then only 15 mph. We drained gas and put in moisture remover and premium gas. Nothing. Changed plugs. checked compression. Checked gas press. Took the EMM from the other ski and I could get 52 mph. Still runs rough but thought that was due to the EMM not being "tuned" to the engine. Knowing all this how confident would you be that it is the EMM? I want to be sure since it looks like this is a pricey fix.
    Do you know any rebuild places?
    about how much does it cost?
    Thanks
    Craig
    McAlester, OK


  2. #2
    boomanch1967's Avatar
    Join Date
    Jun 2010
    Location
    New Carlisle, OH
    Posts
    205
    +1
    2

    DFI Technologies, Inc

    Quote Originally Posted by craig4him View Post
    I bought two 2003 MSX140 early in 2009 that had 9 hours. yup 9 hrs. I have 71 hours now. I ran about half the summer and now the engine doesn't have any power. It is missing and sometimes I could get up to 40 mph by nursing it. Then only 15 mph. We drained gas and put in moisture remover and premium gas. Nothing. Changed plugs. checked compression. Checked gas press. Took the EMM from the other ski and I could get 52 mph. Still runs rough but thought that was due to the EMM not being "tuned" to the engine. Knowing all this how confident would you be that it is the EMM? I want to be sure since it looks like this is a pricey fix.
    Do you know any rebuild places?
    about how much does it cost?
    Thanks
    Craig
    McAlester, OK
    Google DFI Technologies, Inc. They have a diag charge, and it applies forward if something is wrong that can be repaired. Varying prices, 250 ish on the Diag fee, 500-700ish on the repair. Cannot always be fixed, follow instructs on their site, print form, fill it out, box up the EMM, stick in the form, call them let them know it is coming, ship it, and wait for your answer. Their site talks about 2-3 days turn. I sent one to them last thursday, and am expecting to hear something tomorrow from them.

  3. #3
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,587
    +1
    1,272
    Links and contact info for DFI Technologies can be found below in my signature.

    If you have not done so yet, contact Polaris and check whether each HIN number for your two MSX 140 has had all outstanding service bulletins performed. Some of them were critical for the 2003 MSX 140. One involved EMM replacement.

    Swapping EMM with improved results does suggest you have a bad EMM there.

    Do not continue to ride with the swapped EMM. EMM are matched to individual injectors. Mismatched EMM+injectors can cause lean operation and piston damage.

    If you want to confirm the engine runs properly with the swapped EMM, also swap the injectors over to match the EMM, then test ride again. It should perform properly. It may take a short while for the EMM to 'learn' the different TPS, but it should run reasonably well afterwards.

  4. #4

    Join Date
    Jun 2009
    Location
    McAlester, OK
    Posts
    11
    Thanks for all your comments. DFI said the EMM checked out good on the computer. They even put it on an MSX140 and that went good. They are sending it back. Didn't charge me anything. I wil just pay shipping. I asked them what their thougts were. He asked what the fuel pressur ewas I told him 24 psi. Seemed a little lazy getting there when i had it on a water hose to keep it cool. Started it and reved it up a few times. When I was talking to him, I wasn't sure of the specs but 20 to 30 is acceptable. Off of memory he thought it needed to be higher and suggested changing the fuel regualtor. I thought that the Polaris reg was in the tank and he thought an in-line Kawaski regulator would work. I saw in annother post that someone was thinking of using a Kaw reg part #16162-3701 and K447 said to put it past the schrader valve and before the tank. Since my pressure is ~OK I am not to confident that is my problem. He also suggested swapping the EMM that he is sending back and pt it on the other ski to check it out. If it runs good that would confirm the EMM is OK. Then back to the original ski to compare what is different.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FS 2003 MSX140 FICHT EMM Module and Matching Fuel Injectors
    By grumpy_steven in forum Polaris Classifieds
    Replies: 9
    Last Post: 09-28-2014, 07:06 PM
  2. 2003 msx140 emm testing
    By Git-R-done in forum MSX/Matrix
    Replies: 3
    Last Post: 08-18-2010, 07:59 AM
  3. WTB-EMM for 2003 MSX140
    By ifixcars in forum Polaris Classifieds
    Replies: 5
    Last Post: 05-20-2008, 10:17 AM
  4. Replies: 77
    Last Post: 11-24-2007, 11:42 PM
  5. 2003 Msx140
    By Scott M. in forum Polaris Open Discussion
    Replies: 2
    Last Post: 11-24-2007, 11:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •