Results 1 to 2 of 2
  1. #1

    HELP: 2008 GTX Power Loss, where to start looking????

    I have a 2008 GTX which normally runs ~52-54MPH at 7240RPMs. This past weekend we had the ski out and it felt sluggish on acceleration, took longer to plane, and would only hit 45/46 MPH in calm water, RPMís were still @ ~7240. Also the ski had difficulty pulling a wake boarder up. I have pulled the same wake boarder with the same spotter in the past without any problems. I looked at the impeller from the intake and the nozzle and there is no visible damage. Any suggestions on where to start looking and what to look for would be greatly APPRECIATED!

  2. #2


    It was the wear ring. The 2 bottom retaining screws for the ring were missing, the top ones were mostly out of their hole, the wear ring was worn to 50% original thickness where the impeller was and the ring was circulating in it's housing.
    Picked up a new ring and pressed it in today. Dealer said part # 267000104 was replaced with 267000419. Impeller was in good shape and did not need replacing. Overall, not to bad of an item to replace.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 05 GTX LTD LOSS of power
    By bigrich007 in forum 4-Tec Performance
    Replies: 7
    Last Post: 05-15-2008, 12:39 AM
  2. Power loss
    By btownhondaguy in forum Honda Open Discussion
    Replies: 1
    Last Post: 04-28-2008, 08:16 PM
  3. a little loss in power?
    By HallPass in forum Yamaha Open Discussion
    Replies: 3
    Last Post: 06-26-2007, 01:15 PM
  4. '04 GTX 4 Tec Loss of Power
    By coach mike in forum 4-Tec Performance
    Replies: 0
    Last Post: 06-24-2007, 10:31 PM
  5. Power loss
    By mrbtd in forum Yamaha PWC Performance (2-stroke)
    Replies: 16
    Last Post: 04-28-2007, 10:35 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts