Results 1 to 10 of 10
  1. #1

    HELP>>>Gpr1200 bucking bronco!!!

    I have a 01 gpr with the following Riva product....
    Cat. eliminator w/ temp sensor
    Riva heads w/ girdles
    Free flow exhaust
    Solas 13/19 impeller
    Pump seal kit
    Top loader intake grate and riva rideplate

    This ski is runs good but at about 45 mph this thing really goes to jumping out of the water. I did discover this past weekend that when it starts bucking i can lay across the handlebars and it will go away. Then sometimes around 65 mph it goes away on it on. Its really driving me crazy........Anybody know how to fix this problem???? Do I need the Riva trim tabs to solve this or what?


  2. #2
    SvrdRam's Avatar
    Join Date
    Apr 2008
    Location
    Utica, Mi
    Posts
    267
    No, IMO is that the riva tabs r not gonna be ur answer. I had the same problems earlier this year. Your best bet is to go to the lake with a hand full of washers and without the girlfriend because this is.going to take you some time. I would start off with around .130 under each tab and see if that helps...can't comment on shims on the ride plate since I don't run a stocker

  3. #3
    txgp1300r's Avatar
    Join Date
    Apr 2006
    Location
    Dallas , Texas
    Posts
    3,381
    +1
    165
    you need to measure the angle of your plate......a 1200 grate and a plate angle of around .910 should get you in the ball park.

  4. #4
    Happily Self-Employed WFO's Avatar
    Join Date
    Nov 2005
    Location
    Houston, Texas
    Posts
    12,800
    +1
    449
    step the sponsons... they are probably all the way up

  5. #5
    I'm new to the pwc world.....what exactly is a plate angle of .910? How do you go about measuring that?

  6. #6
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    Russ Welcome to the Hulk.

    Start by reading the sticky's @ the top of this section.

    http://www.greenhulk.net/forums/foru...ke-Performance

  7. #7
    gp1200rider's Avatar
    Join Date
    Mar 2008
    Location
    MD
    Posts
    987
    +1
    47
    did you just buy this ski ?

  8. #8
    Yea I bought about two months ago and have been just trying to get a feel for it. I did step the sponsons with them all the way down in back and up in the front. It helped calm down the bucking but it doesn't turn as well now. With the gas alarm going off saturday on fairly smooth water my speedo read 75.....does this seem right?

  9. #9
    PolarisNut's Avatar
    Join Date
    Dec 2006
    Location
    Lower Michigan
    Posts
    1,809
    Quote Originally Posted by RussGPR1200 View Post
    I have a 01 gpr with the following Riva product....
    Cat. eliminator w/ temp sensor
    Riva heads w/ girdles
    Free flow exhaust
    Solas 13/19 impeller
    Pump seal kit
    Top loader intake grate and riva rideplate

    This ski is runs good but at about 45 mph this thing really goes to jumping out of the water. I did discover this past weekend that when it starts bucking i can lay across the handlebars and it will go away. Then sometimes around 65 mph it goes away on it on. Its really driving me crazy........Anybody know how to fix this problem???? Do I need the Riva trim tabs to solve this or what?
    Anybody else think this may have been installed incorrectly? Is your pump shoe hanging down below the surface of the hull?

  10. #10
    gp1200rider's Avatar
    Join Date
    Mar 2008
    Location
    MD
    Posts
    987
    +1
    47
    it sounds like my old ski it needed some more washers in rear and some tuning on plate alot of them had this problem , I seen it listed on ebay recently .

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need Help Fixing up 2000 GPR1200 before summer!!!
    By corycardenas28 in forum Yamaha PWC Performance (2-stroke)
    Replies: 18
    Last Post: 01-26-2014, 05:23 AM
  2. 01 GTS with new engine no throttle response please help
    By xprider02 in forum 2-Stroke Performance
    Replies: 1
    Last Post: 07-24-2010, 02:18 AM
  3. '90 GT Yellow engine & white carb help
    By TNStreamy in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 09-12-2009, 11:02 AM
  4. Sold The 1995 Gts, Now What? 2002 Gti? Help!
    By CENA in forum 2-Stroke Performance
    Replies: 0
    Last Post: 08-06-2008, 03:44 PM
  5. help gts 96 seadoo
    By whipdoo in forum 2-Stroke Performance
    Replies: 0
    Last Post: 10-16-2007, 05:25 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •