Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1

    Just Cranking over

    Hey guys wondering if you might have any ideas I had a friend driving my 2005 RXT 215 hp and it appeared to die on him he said it started back up then died again. When it died I guess he kept trying to start it and weakened the battery so when I arrieved it was just clunking. I now have charged it up and it just turns over. I was wondering if there are any checks I can do to elimanate some possibilitys. Thanks


  2. #2

    Join Date
    May 2008
    Location
    metairie,la
    Posts
    709
    friends dont let friends drive there skis unless they have a lot of money to fix them.....make sure it is firing!

  3. #3
    Life is Supercharged (without ceramics)
    Join Date
    Jul 2008
    Posts
    168
    +1
    1
    so it wont start anymore?

    trying to restart it wont kill the battery. I have a 2005 myself and the battery can take a lot of abuse.

    Here is a little advice from issues i had myself
    1. Check impeller for any stuck pieces of wood/plastic around shaft a bag perhaps?
    2. check the oil for milky residue, if oil looks normal, move to step 4
    3. how is the oil level?
    4. check plugs, are they tight?
    5. remove spark plugs, shine light into cylinder holes, do you see a thin liquid that looks like water? if you do then its most likely your intercooler that is leaking which was what mine was doing. The engine is probably trying to compress water hence it cant turn over and is struggling making it seem like its the battery.

    6. Lastly, never let your friends ride your ski

    I can send you a detailed post from my own experience with water ingestion, its not the end of the world just as long as your buddy didnt ingest too much water and bent a valve or worse.

    Hopefully its simpler than that.
    Good luck

  4. #4
    Thanks for the advise BUTT SHE was way to hot to say no to. I pulled the plugs and noticed the plugs were fouled and I think it might have just been flooded with fuel. I buying new plugs today and want to give it an oil change. Hopefully that take care of it. Thanks

  5. #5
    Life is Supercharged (without ceramics)
    Join Date
    Jul 2008
    Posts
    168
    +1
    1
    Quote Originally Posted by dalino8 View Post
    Thanks for the advise BUTT SHE was way to hot to say no to. I pulled the plugs and noticed the plugs were fouled and I think it might have just been flooded with fuel. I buying new plugs today and want to give it an oil change. Hopefully that take care of it. Thanks

    lol it was her BUTT that got you in trouble

    what kind of plugs were you running when the issue occurred? Even with my 5 year old plugs my rxp would start up just not feel as alive thats all.

    If the issue persists try grounding one of the plugs and turning it over, check to see if it sparks until you find the culprit. It may be an electrical issue but i doubt it.

    Good luck, hope she comes alive.

  6. #6
    Hi thanks for your info I was using NGK. I just got the seadoo started,seems a bit rough so I put the new plugs in I'm not sure if it sounds like a knock I haven't really ran it with the seat off. What would it do if there was a bent valve?

  7. #7
    Life is Supercharged (without ceramics)
    Join Date
    Jul 2008
    Posts
    168
    +1
    1
    Quote Originally Posted by dalino8 View Post
    Hi thanks for your info I was using NGK. I just got the seadoo started,seems a bit rough so I put the new plugs in I'm not sure if it sounds like a knock I haven't really ran it with the seat off. What would it do if there was a bent valve?
    is it very rough at idle on the trailer or is this on water?

    mine is a bit rumbly too but it went away with better iridum plugs either DCPR8EIX or denso iridum IX27 which is what im running now.

    Bent valve
    - you would see blue smoke
    - lower rpms
    - struggling
    - oil consumption
    - oily plugs

    I would check to see if the roughness goes away after idle it should get calm around 3-4k rpm.

    You can tell if you have a bent valve because 1. it will be run very rough and not want to go, 2. wont reach the same redline as before, 3. eat a lot of oil since it leaks around the valves.

    So before you head out next time be sure to check your oil level and keep the jet level with a bubble gauge, run the jet check the rpms and see if it feels normal. Then when you get back home let it cool down, check the oil level and also remove the plugs to check for oil on them.

    Take a pic of the plugs as well so others can chime in.

    Side note, you will also see the jet pump blue smoke out the rear if its eating oil/bent valves. It will vibrate at high revs if its misfiring or becoming fowled in any of the cylinders. Again the plugs will show oil or unburned gas.

    I hope its not a SC charger failure tho, do you have metal washers on your RXT? I believe they still had ceramics until later years. Quick way to check is to see if your SC impeller spins freely or if it has any play in and out by removing the hose going to the SC and intake tubing you can feel it with your finger (engine off of course).

    Cheers
    C

  8. #8
    outboard john's Avatar
    Join Date
    Jun 2006
    Location
    Escondido, Ca.
    Posts
    474
    +1
    2
    If you had water ingestion you probably would have seen traces of moisture on the plugs, and if that were the case I would be much more concerned with a bent rod than a bent valve. That would more likely be your knock if it in fact it is knocking. If you have not upgraded to metal s/c washers I would not start the ski again with out checking the s/c first! This could be something as simple as fouled plugs or something so serious it requires tearing down an engine. Hope for simple.

    OBJ

  9. #9
    Yes I have the metal washers I got them done through here. IT was flooded I pulled the plugs they were fouled grounded them it turned over better you could see a mist of gas coming out of the plug holes put new. Its start easy now with new plugs it just seems to be running off the hose a little rough. Thanks guys

  10. #10
    Life is Supercharged (without ceramics)
    Join Date
    Jul 2008
    Posts
    168
    +1
    1
    Quote Originally Posted by dalino8 View Post
    Yes I have the metal washers I got them done through here. IT was flooded I pulled the plugs they were fouled grounded them it turned over better you could see a mist of gas coming out of the plug holes put new. Its start easy now with new plugs it just seems to be running off the hose a little rough. Thanks guys
    Have you had it in the water yet?

    Mine has some impeller noises on the hose too but its silent on the water. Check your redline on the water and the roughness should go away too.

    Good luck

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 05 aquatrax r 1200 no crank over just clicks
    By kdevarney in forum Honda Open Discussion
    Replies: 2
    Last Post: 09-06-2015, 09:38 AM
  2. 2001 GTX RFI 787 ,Cranks over but won't start
    By dommasr in forum 2-Stroke Performance
    Replies: 0
    Last Post: 06-29-2011, 11:31 PM
  3. Gpr 800 Wont crank over it just clicks?
    By wickedwhiteIX in forum Yamaha PWC Performance (2-stroke)
    Replies: 6
    Last Post: 06-08-2011, 03:29 PM
  4. 1996 GSX with 787 having a hard time cranking over
    By carms_us in forum 2-Stroke Performance
    Replies: 6
    Last Post: 09-16-2010, 10:14 AM
  5. just came over from Riva
    By DJFRANKIEB381 in forum Yamaha PWC Performance (2-stroke)
    Replies: 10
    Last Post: 03-21-2007, 09:39 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •