Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1

    How to clean weeds out of impeller?

    I have done a search and have not found any threads. I have a 2009 RXT IS. Is there a way to lift the gate at the end of the jet so you can access the jet? Will weeds be visible (they are not from the front) Thanks. If there aren't weeds I guess something else broke...


  2. #2
    Well, got the back gate open. No sign of weeds from the front or the back. Either they are deep inside or something else broke.

  3. #3
    2017 RXT-X 300 zone 5's Avatar
    Join Date
    Jun 2007
    Location
    Lake Luzerne, NY
    Posts
    589
    +1
    8
    why do you think you have something in there? Is it vibrating? If thats the case, you could have any really small object (I've had tiny pieces in there) between the impellor blades and the wear ring. shine a light in there, look really carefully and you will probably find it.

  4. #4
    mstennes's Avatar
    Join Date
    Jul 2006
    Location
    On the Columbia River above a Dam
    Posts
    843
    +1
    1
    We have allot of milfoil here, and you know when you plug your pump, it cavitates and pretty much just quits going and over heats.

  5. #5
    Pauly C. Small Paul's Avatar
    Join Date
    Jul 2008
    Location
    Jacksonville, FL, United States
    Posts
    678
    +1
    1
    Well, I can say that I am very well versed in this area. The harbor we ride has a BIG seaweed problem. Usually, when the ski is clogged, you will notice an increase in cavitation upon accelleration if it is bad. if it is not as bad, you will notice a vibration at higher speeds. In both cases, with extended riding, you will get a high temp alarm. the fix is usually fairly simple. Get into the water, and feel under the hull at the front of the sponsons. At the middle of the hull you'll notice a large clump of weed at the intake grate. Remove and throw it at your riding partner that is probably laughing at you. get back on the ski, and you're good to go. In some cases, the weed may wrap itself around the driveshaft. This will need to be removed while on the trailer, and you'll probably need something a little longer to get at it.


    After re-reading your first post, disregard what I typed above.

    +1 on the wearring also.

    Pauly C.

  6. #6

    Join Date
    Jan 2008
    Location
    Canada
    Posts
    226
    Quote Originally Posted by bluesun View Post
    Well, got the back gate open. No sign of weeds from the front or the back. Either they are deep inside or something else broke.
    How did you open the back gate??

  7. #7
    2017 RXT-X 300 zone 5's Avatar
    Join Date
    Jun 2007
    Location
    Lake Luzerne, NY
    Posts
    589
    +1
    8
    Quote Originally Posted by grover432 View Post
    How did you open the back gate??
    This should do it for you



    Click image for larger version. 

Name:	Image1.jpg 
Views:	1119 
Size:	61.0 KB 
ID:	209691

  8. #8

    Join Date
    Jul 2005
    Location
    SE Texas
    Posts
    396
    +1
    3
    I carry a long screwdriver and a set of 16" or so needle nose pliers (harbor freight). I've used the screwdriver to unjam junk from the pump/impeller from underneath throgh the grate. I've also used it to remove vegitation from the intake area and from around the shaft.

  9. +1 by:


  10. #9
    Well apparently there was no debris in the impeller. However, the splines have broken off the drive shaft. Sea Doo told the dealer to check for engine alignment as the dealer had never seen this before. Was about a mile from the ramp (which had a lot of sea weed) and the thrust cut out. Was making a whirring noise, but no thrust. Engine overheated fairly quick, in fact bottom near grate was hot when I tried to feel for debris. Hopefully it will be fixed quick.

  11. #10

    Join Date
    Jul 2005
    Location
    SE Texas
    Posts
    396
    +1
    3
    Did you get a engine temp warning ?

    Keep us informed-- I"m curious as to what might have caused the drive shaft problems.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. how to get water out of inner liner 2000 GPR HELP
    By h2jim in forum Yamaha PWC Performance (4-stroke)
    Replies: 1
    Last Post: 10-15-2011, 12:25 PM
  2. how to more speed out of a group k 1390 in xlt 1200
    By rideryamaha in forum Yamaha PWC Performance (2-stroke)
    Replies: 7
    Last Post: 09-15-2010, 10:50 PM
  3. How to run motor out of the water?
    By Luckyme in forum Polaris How To & FAQs
    Replies: 4
    Last Post: 08-10-2010, 08:31 AM
  4. How to get water out of "styrofoam tank" in FX HO ***pic inside***
    By TJBrad04 in forum Yamaha Open Discussion
    Replies: 0
    Last Post: 07-12-2010, 06:13 PM
  5. How to get rope out of cylinder?
    By redfro in forum Polaris Open Discussion
    Replies: 7
    Last Post: 07-01-2010, 08:39 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •