Results 1 to 8 of 8
  1. #1

    2000 genesis ficht wont rev up above idle please help!!

    i have a 2000 ficht polaris genesis it will start right up and idle just fine when i advance throttle it will stay at idle i have good fuel pressure, good fuel regulator,good spark plugs. the red light flashes as well as the check engine display. dealer claimed their were no codes stored in computer. i just installed new reeds in all cylinders becase one was broken. could the computer be going into a limp mode?? it will idle really well but will not rev up. any help would be greatly appreciated thank you.


  2. #2

    Join Date
    Apr 2006
    Location
    panama city beach 'fl
    Posts
    1,846
    +1
    9
    make sure tps plug in or could be bad

    cd

  3. #3
    tps is plugged in weill a bad tps cause this type of problem??

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,575
    +1
    1,272
    If you have a red flashing light and Check Engine message then you probably have stored codes.

    A bad TPS can cause the symptoms you describe. The only reliable test is another good TPS.

    Unplug the TPS. Does the red lamp go out, and the Check engine message go away? If yes, replace the TPS.

  5. #5
    thanks for the help guys i installed a new tps and it has seemed to cure my problem thanks again

  6. #6
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,575
    +1
    1,272
    Quote Originally Posted by rspray View Post
    thanks for the help guys i installed a new tps and it has seemed to cure my problem thanks again
    That was quick!

    Did you try the start-and-idle test with unplugging the old TPS, or just went straight to a new TPS?

  7. #7
    yes i did try to unplug tps it would still not rev up and the check engine light was still flashing. so i replaced the tps and the rpm came up when i ran it on the water the check engine light will still come on and go out it is kind of strange it seems to have a little miss in the engine yet. i just replaced the reeds with boeyesn dual stage reeds. it does not seem to make the power as it had before i replaced the reeds and tps.i am maxing out at 6000 rpms. is this normal?? thanks again for all of your help.

  8. #8
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,575
    +1
    1,272
    Quote Originally Posted by rspray View Post
    yes i did try to unplug tps it would still not rev up
    Of course it won't rev up with the throttle sensor unplugged.
    The test was whether it would start and idle without the sensor plugged in.


    and the check engine light was still flashing. so i replaced the TPS and the rpm came up when i ran it on the water the check engine light will still come on and go out

    it is kind of strange it seems to have a little miss in the engine yet.

    i just replaced the reeds with Boeyesn dual stage reeds.

    it does not seem to make the power as it had before i replaced the reeds and tps. i am maxing out at 6000 rpms.

    is this normal??
    I don't know exactly what effect the aftermarket reeds will have, but unlike a carburetor engine better reeds will not create more power. The EMM will not be sending any more fuel to the injectors, regardless of which reeds you install. The EMM has no sensor for air flow into the engine, only throttle position.

    If the Check Engine light is coming on, then there is a problem. Read the Trouble Codes from the EMM using the LED light method.

    6,000RPM at WOT is not quite normal. Should be 6500RPM or better, give or take.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 22
    Last Post: 08-29-2016, 05:19 AM
  2. 2000 Genesis Carbed, just dies intermittant on water? Please help
    By rksnow1 in forum Polaris Open Discussion
    Replies: 1
    Last Post: 07-07-2012, 05:08 PM
  3. polaris 780 idles but wont rev up likes its bogging down
    By eam9842 in forum Polaris Open Discussion
    Replies: 5
    Last Post: 08-21-2011, 09:23 PM
  4. 2000 Genesis Ficht...Idle restricted to 2000RPM. Tech says bad EMM.
    By cfellers1 in forum Polaris Open Discussion
    Replies: 4
    Last Post: 08-25-2010, 07:46 PM
  5. GP 1200 Wont rev up past idle Please Help!
    By CJean386 in forum Yamaha How To & FAQs
    Replies: 17
    Last Post: 07-03-2007, 10:05 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •