Results 1 to 4 of 4
  1. #1
    been around the block Stagesrt4's Avatar
    Join Date
    Mar 2010
    Location
    S. elgin
    Posts
    395

    ? After rollover n water in motor....yadayada

    On vaca last week my 300pound cousin was on my 97 XP. I guess he spilled pretty bad and he says the ski tumbled/rolled a few times.

    I towed ski to my beach spot n proceeded to inspect ski.

    There wasn't any water in hull at all but when I pulled plugs, I found that motor was loaded w/water. I drained the battery getting all the water out and cleaned plugs. Got her up and running and ran perfect for rest of week...still working same as before currently...


    Do I need to drain the crank case somehow tho or any other process I should perform?

    Thanks guys


  2. #2
    flyin' the friendly skies airbornexp's Avatar
    Join Date
    Aug 2007
    Location
    Mahomet, Il. USA
    Posts
    6,004
    +1
    163
    nope...as long as you got the water out and ran it for a while you should be good to go. it doesnt bog or stall does it?

  3. #3
    been around the block Stagesrt4's Avatar
    Join Date
    Mar 2010
    Location
    S. elgin
    Posts
    395
    It hesitates a lil when u floor it from a stop but it did it before.

    I was thinking it was the accelerator, so didn't relate that to this...



    I put at least 5 hours on it after the flooding.

  4. #4
    flyin' the friendly skies airbornexp's Avatar
    Join Date
    Aug 2007
    Location
    Mahomet, Il. USA
    Posts
    6,004
    +1
    163
    you should be good then...just need to figure out what your hesitation is

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. spx water in motor
    By mikeymuy in forum 2-Stroke Performance
    Replies: 8
    Last Post: 07-15-2009, 01:28 PM
  2. Water in motor - 97 XP 787
    By skidooosl in forum 2-Stroke Performance
    Replies: 5
    Last Post: 07-07-2008, 11:20 AM
  3. Water in motor, help!
    By GP1300RnPVB in forum Yamaha PWC Performance (2-stroke)
    Replies: 25
    Last Post: 08-06-2007, 09:12 PM
  4. Water in motor
    By billywilly in forum Polaris Open Discussion
    Replies: 3
    Last Post: 07-04-2007, 07:45 PM
  5. Water in motor
    By explude in forum Polaris How To & FAQs
    Replies: 4
    Last Post: 06-18-2007, 07:56 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •