Results 1 to 8 of 8
  1. #1
    bustercherry's Avatar
    Join Date
    Jan 2006
    Location
    Portland, Oregon
    Posts
    10

    My Riva intake grate broke and parts went through and my pump on my 2008 RXPX stage1.

    Sent my impeller to Impros to have it fixed(good idea?) Put in new wear ring and refurbed impeller and installed new R&D intake grate. Lost a little power. Running about 95%(pump shoe looks good and pump vains look good. Any ideas? It had a slight vibration when i first fired it at the river, but seem disappear.

    Thankyou for any help!


  2. #2
    dnielsen's Avatar
    Join Date
    May 2008
    Location
    Shreveport, Louisiana
    Posts
    2,018
    +1
    94
    The R&D grate is a much better grate, just changed from Riva to Worx, ran one time and switched to the R&D. The R&D is a much heavier made grate, I think you solved you grate braking issue. When you had the pump apart did you check the shaft for any deflection? To do you'll need a dial indicator (maximum amount of deflection should be 0.5 mm or .020 in. you'll need a pair of v-blocks or something simular to hold the shaft while spinnng by hand to gauge (must pull shaft to check). Only other thing that comes to mind is a badly repaired impellar, if you had a spare you could swap and test for vibration, even if its the wrong pitch it would only be a temp. Would be easier than pulling the shaft and having to locate, barrow, or purchase the other tools for checking shaft deflection.

  3. #3
    bustercherry's Avatar
    Join Date
    Jan 2006
    Location
    Portland, Oregon
    Posts
    10
    Thanks for your input. I just sent another impeller to Impros that took a rock. When i get it bake i will put it in to see if that is it. A question regarding checking the shaft: Why cant you check it by removing the intake grate and hooking a hose up to it and firing the ski up?

  4. #4
    formerly Gold06RXP Turbo Nick's Avatar
    Join Date
    May 2007
    Location
    Dayton, OH
    Posts
    2,095
    +1
    97
    What did that feel like? Did you get tosed off?

  5. #5
    bustercherry's Avatar
    Join Date
    Jan 2006
    Location
    Portland, Oregon
    Posts
    10
    I thought the motor blew. I was on the juice and alll of a sudden a here a horribal grinding noise and the exhaust alarm on the ski was going off(dont understand that part). It didn't throw me but it did slow down hell of alot faster then normal. A couple of pieces were caught around(behind) the impeller and was making a loud wining noise. My bros could here it from across the river. Limped it back and after some time looking under the seat checked under the ski. I think i got lucky over all no bolts were pulled out. The part that sucks is literally 5 min. before that i blew my exhaust gasket on my Kaw SXR standup ski. So i was time to take drinking beer seriously!

  6. #6
    Having Fun jp1300r's Avatar
    Join Date
    Sep 2005
    Location
    Florida
    Posts
    5,334
    +1
    261
    Hows the pumpshoe look? What are your RPMs now?

  7. #7
    dnielsen's Avatar
    Join Date
    May 2008
    Location
    Shreveport, Louisiana
    Posts
    2,018
    +1
    94
    You might get lucky and spot it if its bent bad enough without pulling the shaft. Remember your looking for a maximum of 1/2 a mm in deflection for a bad shaft. There is really no way to check properly on the ski, you would run the risk of getting a bad reading or measurement due to a possible loose or bad bearing or worn splines or dampner. JP had a good question, whats the shoe look like?

  8. #8
    bustercherry's Avatar
    Join Date
    Jan 2006
    Location
    Portland, Oregon
    Posts
    10
    Last year i took a rock and it broke one of the plastic blades on the pump shoe and per this forum(thankyou very much) i just filed all of them down to nothing nice and smooth. And no power loss noticable at all.

    I did a good inspection of the pump shoe and the fiberglass infront of the shoe after the intake grate issue and it all looks great.
    So it looks like i will try the other referbed impeller when i get it back next week. Hope that's it! If not looks like i'm pulling the shaft!

    I will let ya know.......

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Broke my RIVA intake grate RXPX?!? (pics) Opinions/options?
    By Mikey G. in forum 4-Tec Performance
    Replies: 29
    Last Post: 09-18-2012, 08:19 AM
  2. FS FZR Riva intake grate and Seal Kit (NEW)
    By gmoeller in forum Yamaha Classifieds
    Replies: 7
    Last Post: 03-10-2010, 08:23 PM
  3. FZR/S R&D and Riva intake grate????
    By SpeedJunky in forum Yamaha PWC Performance (4-stroke)
    Replies: 13
    Last Post: 10-20-2009, 07:30 AM
  4. WTB WTB: 2.5 degree wedge, SR-CD-13/20R, and gtx sc 185hp riva intake grate. P
    By Tampa Florida in forum Sea Doo Classifieds
    Replies: 0
    Last Post: 09-11-2009, 11:34 PM
  5. WTB: Prop (15/20 4-Blade) and Riva Intake Grate
    By OneEyedHito in forum Sea Doo Classifieds
    Replies: 0
    Last Post: 06-15-2009, 03:21 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •