Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 21
  1. #1
    Hueneme Beach Ca.
    Join Date
    Jul 2010
    Location
    Hueneme Beach Ca.
    Posts
    73

    BAD day at the Harbor for somebody

    I feel bad for these kids. I drove up to the ramp just in time to see the truck going backwards as the kid was trying to get his ski on the trailer. It pushed him back and he sort of flipped over. The ski was shooting a jet of water up in the air and he was trying to catch it.





    It looked like the truck was going to stay like this and then the water got to the top of the door. It sank like a rock after that.



    I'm sure he knocked it out of gear or something. He swears it was in gear and it just slid on the green slime.

    Scared me. I backed down and made damn sure I was out of the slime.



  2. #2
    ChargedTaco's Avatar
    Join Date
    May 2010
    Location
    Hawaii
    Posts
    217
    Quote Originally Posted by Vettepro View Post
    I feel bad for these kids. I drove up to the ramp just in time to see the truck going backwards as the kid was trying to get his ski on the trailer. It pushed him back and he sort of flipped over. The ski was shooting a jet of water up in the air and he was trying to catch it.


    It looked like the truck was going to stay like this and then the water got to the top of the door. It sank like a rock after that.



    I'm sure he knocked it out of gear or something. He swears it was in gear and it just slid on the green slime.

    Scared me. I backed down and made damn sure I was out of the slime.

    Hard to follow but I get the jist of it. I'm glad I have 4wd should I ever need it.

  3. #3
    ObsoleteE's Avatar
    Join Date
    Aug 2010
    Location
    Rochester NY
    Posts
    117
    +1
    1
    Damn, that sucks for him. This is why I shut my truck off, put it in first gear (MTX) and push that e-brake pedal down real hard.

  4. #4
    I have a similar story. Somehow I left my truck in reverse and got out to take the ski off of the trailer a few weeks ago when launching it into a boat ramp. I started going to the ski to unhook it from the trailer when I realized that the truck was moving into the water . Somehow I managed to get to the driver's side door and apply the break with my right hand before the truck went too far into the water. Needless to say I freaked out my family and neighbors (who saw it all happen) as well as scaring the hell out of myself. I guess I was lucky...

  5. #5
    SurfRider's Avatar
    Join Date
    Jun 2010
    Location
    NJ
    Posts
    735
    +1
    13
    Vettepro. Yeah that must have really sucked for them! I am still amazed that you would try this with your Vette. I would never try this with my 911. I will only ever use my Chevy van. There is a big difference between the tires we use on our "performance" cars vs. our "trucks". I would not trust a ZR+ rated tire on any slick surface (or in my case R compound tires). Also our cars have way too much horsepower for that. It would be way too easy to start spinning the tires instead of slow and steady power of a truck (unless you had 4wd vehicle). Yeah a posi rear may help, but I have that in my van too.

  6. #6
    hitman's Avatar
    Join Date
    Aug 2006
    Location
    Ft. Lauderdale, FL
    Posts
    4,328
    +1
    12
    That is going to be your Z06 one day. Do you not have anything else you can pull the ski with?

  7. #7
    Banned User
    Join Date
    Aug 2009
    Location
    Discovery Bay, CA
    Posts
    3,048
    +1
    336
    i know first hand they can slip in the slime. when they pulled my truck out it was still in park with the ebrake set!!

  8. #8
    Hueneme Beach Ca.
    Join Date
    Jul 2010
    Location
    Hueneme Beach Ca.
    Posts
    73
    Quote Originally Posted by hitman View Post
    That is going to be your Z06 one day. Do you not have anything else you can pull the ski with?
    My Trailblazer is out of commission. That's why I built the hitch for the Z06.
    I bough the ski the day before I went on vacation. While I was away one of my mechanics was test driving the Trailblazer, looking for an exhaust rattle. He took off from the stop sign a little to hard and snapped a hardened ouput shaft in the trans. When I got back from vacation I had a brand new ski and no truck, so I figured what the hell. It's good for a backup.
    I bought an extra long trailer this weekend. I can launch and retrieve without getting the tires wet at all.
    The Trailblazer (its AWD) should be back on the road tomorrow with a brand new RPM Level 7 transmission. ( #8 if I remember correctly)
    This thing is rough on transmissions. It was making 22# of boost with a Whipple 3.3 liter blower. That was just out of control.
    I've toned it down to 14# with a custom Vortech setup. It's still brutal.





    You can see why it breaks things !

  9. #9
    08SHOC's Avatar
    Join Date
    Oct 2009
    Location
    Down Under
    Posts
    151
    +1
    5
    I can relate to this , i lauch my ski with a medium sized sedan . I parked it to let the ski off the trailer as i got out of the car it was sliding down the ramp as fast as i could walk .

    If i had off slipped over and not made it back in the car .....this would have been me too. The rear wheels were in the slime and when i took my foot off the brakes after placing the car in park ....it released the front brakes ( off course ) and started to slide .

    The ramp wasn't wet and looked fine ...to this day i walk the ramp first .

  10. #10

    Join Date
    Oct 2008
    Posts
    109
    that really sucks and nice pic of the vette

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 11
    Last Post: 07-10-2012, 12:51 PM
  2. Bad day at the lake!
    By bigboatman in forum Polaris Open Discussion
    Replies: 19
    Last Post: 08-27-2009, 11:33 AM
  3. Bad day at the lake!
    By WICKEDSEADOO in forum 4-Tec Performance
    Replies: 3
    Last Post: 07-12-2009, 10:09 PM
  4. Bad day at the ramp....
    By inothome in forum Videos & Pictures
    Replies: 12
    Last Post: 02-09-2008, 10:45 PM
  5. Bad Day At The Lake....:(
    By dereksabolracing in forum 4-Tec Performance
    Replies: 2
    Last Post: 08-08-2005, 08:17 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •