Results 1 to 6 of 6
  1. #1

    2001 Genesis FICHT fuel injector question..

    I think I finally figured out what was going on with my 01 genesis I..It runs good but from about 1/4 to 1/2 throttle it will bog down...but if you give it 3/4 or full throttle off the start it takes off fine but if you only 1/4 to 1/2 throttle it will bog down and not run properly...I think I figured out its the pto injector that is causing it...i have cleaned it out a few times and it will run good for a few mins or so and then just go back to doing it...before i thought it was just the plugs getting fouled so i changed them and it ran good for a bit then back to the same problem..so my question is this..i have another injector i wanted to put on it but I think it has to be programmed to the new ski am I correct here or can I just bolt it in and go???? Any help on this is appreciated and if you've came across this problem before let me know what the cause was..


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,595
    +1
    1,276
    While it is possible the PTO fuel injector itself is the problem, somehow I doubt it.

    For testing purposes, go ahead and install the spare injector. Just don't ride it long and/or hard. Just enough to prove the injector change solves the problem, or it doesn't.

    You have checked fuel pressure, and it is over 20PSI - correct?

    Voltage on the White/Red wires is 45 volts when engine is running, with all injectors plugged in - correct?

    Do you have a another TPS you could try? Often enough TPS problems have strange symptoms, and it may just be coincidental with your other work that the TPS works better some moments than others.

    There is no method of testing a TPS, other than replacement with a known good TPS.

    BTW, how are you cleaning the injectors?
    If you remove the tips, be sure to never swap the tips around between injectors.

  3. #3

    Join Date
    Aug 2010
    Location
    long island
    Posts
    18
    howu doing man, im joe, cant fix your problem, i have a 03 msx140, good compression120 across the board new cdi box, doesnt run, ex owner says it run but started braking up, it makes a banging noise when u try to start it, i pulled front cover stater looks good, didnt test 4 power. cheaked kill swich thats fine. let me know what u think'' thanks

  4. #4
    K447, First off thanks for the help...

    I will install the spare injector tomorrow (Came off an MSX 140 looks like the same FICHT injector but different part number). did check the fuel pressure but will double check it again tomorrow to see if it changes with the new injector or not??

    I have not checked the voltage so I will do so tomorrow as well as changing the TPS sensor. Will a sensor from an 03 msx 140 work ok? They look like the same part...as for cleaning the injector I just removed it from the head and cleaned it up a bit with some light sand paper and gorilla pad and some carb cleaner.

  5. #5

    Join Date
    Jun 2008
    Location
    Sudbury, Ontario
    Posts
    109
    tps from the msx will work with your genesis, as long as its off the 140

  6. #6
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,595
    +1
    1,276
    Quote Originally Posted by polarisrider007 View Post
    K447, First off thanks for the help...

    I will install the spare injector tomorrow (Came off an MSX 140 looks like the same FICHT injector but different part number). did check the fuel pressure but will double check it again tomorrow to see if it changes with the new injector or not??

    I have not checked the voltage so I will do so tomorrow as well as changing the TPS sensor.

    Will a sensor from an 03 msx 140 work ok? They look like the same part...

    as for cleaning the injector I just removed it from the head and cleaned it up a bit with some light sand paper and gorilla pad and some carb cleaner.
    The tip of the Ficht fuel injector is a very high precision poppet valve. Sandpaper is not a good thing to be using on an injector tip. A nylon scrubbie pad is more than I use. Normally a little carb cleaner on a cotton cloth will do the job.

    The TPS on your 2001 Genesis is different from the version used on the MSX 140. 2002-2004 use a different TPS than 1999-2001. The difference is in how the TPS connects to the shaft of the throttle body.

    Electrically, they are interchangeable. You can plug the MSX 140 TPS into the Genesis connector, but you would have to hand hold the shaft of the TPS in the idle position (not easy to do with any accuracy). Idle position is NOT at the end of rotation for the TPS, it is slightly above. The EMM watches the TPS position, and will flag the TPS Trouble Code, or even refuse to start, if the TPS signal is out of range.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Polaris Genesis 2001 1200 Ficht fuel injected, need breaker/fuse box
    By shadetreejerry in forum Polaris Open Discussion
    Replies: 2
    Last Post: 07-07-2013, 01:37 PM
  2. 2001 Genesis Ficht poor performance
    By WaveChaser in forum Polaris Open Discussion
    Replies: 53
    Last Post: 09-13-2010, 09:54 AM
  3. polaris genesis 1200 oil injector question
    By dahank in forum Polaris Open Discussion
    Replies: 12
    Last Post: 06-21-2010, 10:53 PM
  4. Genesis EMM Fuel Injector Question
    By VegasRatt in forum Polaris Open Discussion
    Replies: 1
    Last Post: 11-06-2006, 08:59 AM
  5. Fuel Injector Question
    By VegasRatt in forum Polaris Open Discussion
    Replies: 8
    Last Post: 10-08-2006, 01:29 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •