Results 1 to 7 of 7
  1. #1

    Join Date
    Sep 2006
    Location
    San Juan, Puerto Rico, Puerto Rico
    Posts
    127

    The problem on the engine of msx 140

    Hello buy Msx 140 2003 with 52 hours of use and when to start the engine makes an explosion, we have changed the TPS again, verify the Stator capacitor and is in good condition, FUEL SYSTEM PRESSURE 20 PSI and the Crankshaft Position Sensor on new, which the next step would be to change the EMM is sent to check it and said it was good


  2. #2

    Join Date
    Aug 2010
    Location
    long island
    Posts
    18
    i have the same boat and i cant get it running, gd comp. 67 hrs, it makes a banging noise when i try to startit, no fuel on plugs, can u help

  3. #3
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,591
    +1
    1,275
    Quote Originally Posted by joseph27 View Post
    i have the same boat and i cant get it running, gd comp. 67 hrs, it makes a banging noise when i try to startit, no fuel on plugs, can u help
    Backfiring when trying to start a Polaris fuel injected 2-stroke is an indication that the EMM probably needs repair.

    You can find more info on Ficht EMM repair in the links below.

  4. #4

    Join Date
    Sep 2006
    Location
    San Juan, Puerto Rico, Puerto Rico
    Posts
    127
    I UNDERSTAND THAT EVERY MODEL IN THE POLARIS MSX EMM 140 are calibrated to work with THE INJECTOR PROPERLY, MAKE A TEST WITH OTHER EMM MSX 140 RUNNING TO CONFIRM THAT THIS IS THE PROBLEM IN THE EMM for in February 2010 SE SHIPPING CHECK And indicator that was functioning well, BUT THE PROBLEM WE changed the TPS again, verify the Stator capacitor and is in good condition, FUEL SYSTEM PRESSURE 20 PSI and the Crankshaft Position Sensor on new.

  5. #5
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    Quote Originally Posted by freddypr1 View Post
    I UNDERSTAND THAT EVERY MODEL IN THE POLARIS MSX EMM 140 are calibrated to work with THE INJECTOR PROPERLY, MAKE A TEST WITH OTHER EMM MSX 140 RUNNING TO CONFIRM THAT THIS IS THE PROBLEM IN THE EMM for in February 2010 SE SHIPPING CHECK And indicator that was functioning well, BUT THE PROBLEM WE changed the TPS again, verify the Stator capacitor and is in good condition, FUEL SYSTEM PRESSURE 20 PSI and the Crankshaft Position Sensor on new.
    Have you verified crank index?

  6. #6

    Join Date
    Sep 2006
    Location
    San Juan, Puerto Rico, Puerto Rico
    Posts
    127
    Verified that in the crank index
    Quote Originally Posted by ph2ocraft View Post
    have you verified crank index?

  7. #7

    Join Date
    Sep 2006
    Location
    San Juan, Puerto Rico, Puerto Rico
    Posts
    127
    If any damaged Reed would cause the same problem to start the motor

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. What is the compression ratio of the engine of the sx-r 800
    By ANTONYUK in forum Kawasaki How To & FAQs
    Replies: 2
    Last Post: 02-19-2015, 07:05 AM
  2. Limit the engine of a Yamaha Waverunner 760 to 54hp
    By xa1200 in forum Yamaha PWC Performance (2-stroke)
    Replies: 5
    Last Post: 08-04-2014, 10:09 PM
  3. More problem on my engine
    By samui in forum 4-Tec Performance
    Replies: 19
    Last Post: 02-14-2011, 02:39 PM
  4. more problem on my engine
    By samui in forum 4-Tec Performance
    Replies: 12
    Last Post: 11-24-2010, 01:17 AM
  5. What is maximum speed of MSX 140?
    By xsantia in forum Polaris PWC Performance
    Replies: 8
    Last Post: 11-09-2006, 10:12 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •