Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17
  1. #1

    Join Date
    Aug 2010
    Location
    bellmore NY
    Posts
    7

    high idle 1700-1900, WOT now cutting out to half speed and boost. Help please.07 250x

    Good afternoon all

    2007 250x 140 hours , My idle has been running high this season( 1700 -1900 rpms ) and now I am experiencing my engine cutting out and going down to half power and half boost….
    I got the f1 light once but was unable to get the code off of the dash cpu.
    I took it out again after remembering how to read the code (pressing mode and set together) but was unable to get it to show up again.

    I have ordered a new throttle sensor, in order to try to solve the idle rpm problem, but I am still worried about the engine cutting out to half power by the cpu…

    Once riding at almost WOT the engine will cut down to about 5000 rpms and 5 pounds of boost.
    I am in the process of changing the oil as well (smell a hint of gas in it and about 10 hours on it if that. )

    If any one has any ideas what could be the cause please let me know… as I try to trouble shoot this problem …

    I am also thinking it could be from grounding out on the sand bar one day… But all cooling lines seem clear and haven’t had any over heating problems.


  2. #2
    jmatak9's Avatar
    Join Date
    Jul 2009
    Location
    St. Cloud, Fl
    Posts
    435
    does the ski have any mods? check plugs, and its a possibilty your IC is clogged from oil overfilling, when you say your idle is high, is that in the water vor out of the water on hose?

  3. #3
    jmatak9's Avatar
    Join Date
    Jul 2009
    Location
    St. Cloud, Fl
    Posts
    435
    I forgot, check your belt tension, and BOV could be leaking, if you havent already blocked it.

  4. #4
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    simple sounds like it is going into limp mode you will need to see what the code is. have you advanced the timing? as that also causes high idle.

  5. #5

    Join Date
    Dec 2009
    Location
    SE Asia
    Posts
    370
    +1
    3
    hey nckjak.. after advancing the timing.. idles run higher.. do we then adjust the idling back to the stock rpms ?

  6. #6

    Join Date
    Aug 2010
    Location
    bellmore NY
    Posts
    7
    18500 -19500 on the hose 1700-1800 in the water... belt tension is great ... just had a new supercharger put in this spring... bov is blocked. the ski sounds great... and gets up to speed like it was brand new... but this limp mode is a new problem... I'll have to try to test it out again and get the code to come up.. i have not advanced the timing at all ...

  7. #7
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    some do but this also effects tps, take note where the stopper screw is and back it off i think 1/2-1 turn.

  8. #8
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    check if the throttle cable has play? if not check the tps voltages its all in the manual.

  9. #9
    2005 RXT Red08Ultra250's Avatar
    Join Date
    Feb 2008
    Location
    Dunedin, FL
    Posts
    908
    I would check all the easy possibilites first. Check belt tension with the tool. Check all air intake hoses for tightness. Check plugs. Check that your aibox is not loose and sucking up against the hull at full throttle. Block off the BOV. Any one of these could be causing this.

  10. #10

    Join Date
    Aug 2010
    Location
    bellmore NY
    Posts
    7
    thanks I'll let you know how it goes when i get to it this weekend.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 62T Engine Cutting Out above half throttle
    By Beerme in forum Yamaha PWC Performance (2-stroke)
    Replies: 0
    Last Post: 06-03-2011, 08:37 AM
  2. 01 GP1200r- Feels like one cylinder cuts out while cruising. Stop and restart to fix.
    By wishihad in forum Yamaha PWC Performance (2-stroke)
    Replies: 5
    Last Post: 04-20-2011, 04:20 PM
  3. 95 slt jet boat conversion cutting out at low speed
    By jleworth in forum Polaris Open Discussion
    Replies: 12
    Last Post: 11-13-2010, 12:01 AM
  4. Polaris engine cutting out at low speed
    By jleworth in forum Conversion PWC Performance Skis
    Replies: 2
    Last Post: 11-08-2010, 11:16 AM
  5. SLX cutting out at full speed
    By tothehorizon in forum Polaris Open Discussion
    Replies: 13
    Last Post: 04-21-2010, 08:07 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •