Results 1 to 3 of 3
  1. #1

    Gas Gage does not work?

    I have a 1996 Polaris sl 700 . I have looked and can not find out how to check the gage and or sending unit in the gas tank. The gage does not work, showes empty all the time. How can I test to see which one is faulty.......thanks


  2. #2

    Join Date
    Aug 2006
    Location
    Homer Glen Il.
    Posts
    8,704
    +1
    109
    sounds like you need a new float Contact John Zigler on here he has them instock

  3. #3
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31
    Normally the float goes bad.

    Get a replacement for around $30 from John Zigler or Sharp's Marine.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 02 Seadoo GTX 155 Speedometer does not work
    By crzyjetskr in forum 4-Tec Performance
    Replies: 0
    Last Post: 03-27-2012, 08:21 PM
  2. Replies: 3
    Last Post: 07-17-2011, 11:35 AM
  3. Trim indicator does not work in display
    By Tho in forum 4-Tec Performance
    Replies: 5
    Last Post: 05-21-2011, 08:25 AM
  4. 97 1100 STX flushing. Kaw plumbing su..s (does not work)
    By sbklf in forum Kawasaki Open Discussion
    Replies: 4
    Last Post: 05-01-2011, 02:41 PM
  5. 98GTXL fuel gauge does not work
    By G_Man in forum 2-Stroke Performance
    Replies: 4
    Last Post: 07-10-2007, 08:41 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •