Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 40
  1. #1
    Phil's Avatar
    Join Date
    May 2005
    Location
    Smith Mountain Lake, VA
    Posts
    1,428
    +1
    23

    Question 2010 RXT-X key problem

    I am the only one with a problem starting my RXT-X? It is very hard to get a double-beep when pressing the key on the receptacle. It is so hard, my wife cannot start the ski by herself. This is ridiculous! Sea Doo must have a fix for this problem?


  2. #2

    Join Date
    Jun 2005
    Location
    rome ga
    Posts
    938
    +1
    20
    Have you tried a new dess post?

  3. #3
    www.eastcoastpwc.net Scott's Avatar
    Join Date
    Jul 2007
    Location
    NJ
    Posts
    7,992
    +1
    455
    This is common on most 2010 rxtx's. I think seadoo has a fix out for it. Call your local dealer and ask. This is what a friend told me when he brought his ski in for the 10hr service. He also mentioned the pump bracket check too (which was already mentioned on this forum).

  4. #4
    Phil's Avatar
    Join Date
    May 2005
    Location
    Smith Mountain Lake, VA
    Posts
    1,428
    +1
    23
    Quote Originally Posted by rxpstan View Post
    Have you tried a new dess post?
    Nope. Is this the fix, Stan? I called the dealer and he wants me to bring in the ski for him to look at in order for him to order parts from Sea Doo. I asked the dealer, "Am I the first person to report this problem?". He said," Yep."

    I was just out on the lake a few minutes ago and met a rider with the same ski. He said he was haivng the same problem!

  5. #5

    Join Date
    Jan 2008
    Location
    Canada
    Posts
    226
    Quote Originally Posted by Phil View Post
    Nope. Is this the fix, Stan? I called the dealer and he wants me to bring in the ski for him to look at in order for him to order parts from Sea Doo. I asked the dealer, "Am I the first person to report this problem?". He said," Yep."

    I was just out on the lake a few minutes ago and met a rider with the same ski. He said he was haivng the same problem!
    This problem has been reported on this forum previously. I'm led to believe that some people had problems with their DESS post while others said a key change helped. What helped me was a more deliberate attachment of the key and recognizing the timing issue. I also think that the cup on the end of my key has softened a bit making it easier to attach.

    I use the following procedure: (1) turn the handle bars to the right to expose a better angle on the DESS post and press the start/stop button firmly. (2) Once the tachometer and speedometer needles drop to zero, grasping the key by the tab which hold the umbilical cord (not the round part), wiggle the key cup onto the post, continuing to wiggle it back and forth to make sure it has a good contact. (3) you should hear a double beep

    I was only able to get a good contact 50% of the time when I first got my RXT X. After some practice, I would say I'm able to get a double beep 95% of the time. If you aren't able to get yours to work with the above method, you may need to take a trip to the dealer to check out your post and keys.

    Keep in mind that if you fail to get a double beep, you must remove the key and wait for about 15 seconds before you try again as you need to restart the ECM wake up procedure and then reconnect the key.

    The good news? Once you figure this out, when you stop to talk to someone or are waiting for a skier to get ready to go, you don't have to listen to the annoying double beep of previous models. You have about 3 minutes of off time before you have to restart the ECM.

    Let us know how you make out!

    grover

  6. #6
    JT jpt7779's Avatar
    Join Date
    Jul 2008
    Location
    Pittsburg, Texas Lake Bob Sandlin
    Posts
    3,851
    +1
    742
    I had the same problem early on but not any more. Here's what I do:

    hit the red start button to wake up the ski
    put the key on the DESS post firmly and straight, should hear two beeps, and "Normal Key" on display
    (if you don't hear two beeps -it will NOT start) repeat above
    HOLD the red start button again and it fires up

    I've noticed if you leave the key installed on the post, subsequent starts, it will fire right up on the first red start button push!

    This is DEFINITELY different from past SeaDoo startup prodecures and lots of us have discussed this topic previously!

    Either my ski is not as finicky as before or I've got better starting - not sure......

  7. #7
    Turbo Doo's from Down Under one1one's Avatar
    Join Date
    Aug 2007
    Location
    Gold Coast, Australia
    Posts
    394
    There is a BUDS update available if you have this issue, tell your dealer to refer to campaign # 2010-0009 on BOSSWEB. It effects all 2010 iControl models.

  8. #8
    stuckmoto's Avatar
    Join Date
    Jun 2010
    Location
    Newark, De
    Posts
    1,485
    +1
    59
    Yea, mine is exactly like grover's and JT's. I get it right 95% of the time and have the starting procedure down to a tee. I figure it will help keep my kids from getting any ideas and trying to take off on it.

    @one1one - do you know EXACTLY what this update does?

  9. #9
    Phil's Avatar
    Join Date
    May 2005
    Location
    Smith Mountain Lake, VA
    Posts
    1,428
    +1
    23
    Quote Originally Posted by one1one View Post
    There is a BUDS update available if you have this issue, tell your dealer to refer to campaign # 2010-0009 on BOSSWEB. It effects all 2010 iControl models.
    Thank you, thank you!

  10. #10
    I just cram the key on and hit the starter without waiting for anything to light up and it usually starts then beeps twice.

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2007 RXT Key Problem
    By NastyStang in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 04-26-2012, 10:55 AM
  2. Carbon ring problem? -2010 RXT-X260, 42 hrs.
    By immred in forum 4-Tec Performance
    Replies: 14
    Last Post: 09-17-2011, 01:02 PM
  3. Steering and top speed problems 2010 RXT-X 260
    By zone 5 in forum 4-Tec Performance
    Replies: 48
    Last Post: 08-21-2010, 06:38 PM
  4. 2010 rxt x key issue and mod questions
    By macgyver in forum 4-Tec Performance
    Replies: 20
    Last Post: 06-23-2010, 05:43 AM
  5. 2010 RXT-X 260 D.E.S.S problems
    By Mark82 in forum 4-Tec Performance
    Replies: 1
    Last Post: 06-07-2010, 11:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •