Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1
    jusloungin's Avatar
    Join Date
    Jan 2010
    Location
    fort myers
    Posts
    141

    problem with riva ic

    ok so i had my riva ic installed by riva the first ride i had with it the line that supplies the ic fell off and got a hull full of water so i called riva and they said bring it down and they will tighten it up, well i tighten it up myself just because riva is a 4 hour round trip for me so its been some time since it fell off, well went riding this weekend and guess what again it fell off and i notice it because i always look back and make sure there is water coming out of the rear of the ski, (i dont know how safe that is doing 75 mph) has anyone had this issue i think there has to be some other way to make this stop doing this, oh yea and lee i know the smart comment is coming like this just happend because i did not go riding with you or something so haha, i just need a fix, iam thinking of taking the intake fitting out and putting a strait one instead of a 90 degree one, just looking for some advice, as long as its not lee carlson, just kidding lee


  2. #2
    SHOBiz's Avatar
    Join Date
    Jul 2008
    Location
    Wylie, Texas
    Posts
    3,577
    Myself, I would like to see us getting a more positive connection than a worm gear clamp on a Home Depot brass fitting. Not sure what that would be, just putting that out there.

  3. #3
    jusloungin's Avatar
    Join Date
    Jan 2010
    Location
    fort myers
    Posts
    141
    i was thinking on putting a strait longer fitting on so i can use 2 hose clamps to make it tight

  4. #4
    L Carlson's Avatar
    Join Date
    Aug 2007
    Location
    Bonita Springs, Florida, United States
    Posts
    7,118
    +1
    2
    Hmmm Let think about this and get back with ya! Yes I would def use the straight fitting. Haggertry just changed to that. Might also think about using red locktight on the clamps. That tends to hold the threads from going in reverse Bro. Best of luck. Ohh Logs float just remember that. Your friend Lee Get a real mechanic and stop going to Riva To get your shit done! You 77 mph Fzr needs a trip to Tampa! Have a real guy take care of you. Stop drinking for a day You can then afford your trip to the Tampa area! Might even See 80+ LOL Don't forget to replace all you OEM junk hoses with the good ones! Also the driveshaft hose they collapse. I can add a 1000gpm bildge to help you also!
    That is If you don't do what all your bros tell ya. What to do! or Just take it back to Riva to install one they will only charge you a few cents. Lee

  5. #5
    L Carlson's Avatar
    Join Date
    Aug 2007
    Location
    Bonita Springs, Florida, United States
    Posts
    7,118
    +1
    2
    On second though Chris you better bring it back to Riva You have the Riva Warranty

  6. #6
    L Carlson's Avatar
    Join Date
    Aug 2007
    Location
    Bonita Springs, Florida, United States
    Posts
    7,118
    +1
    2
    Chris Read on this thread how well the Riva Warrenty works out for ya!!! http://www.greenhulk.net/forums/show...-turn-a-wrench

  7. #7
    bkweld's Avatar
    Join Date
    Jul 2010
    Location
    St John's River,N FL.
    Posts
    147
    oh yeah, that's my thread. I've learned so much more about performance and mods by doing my own work (excluding my current predicament) from now on unless my engine blows up, I'll fix it myself. I'm just glad i didn't buy that stupid 5 year warranty, the hell w/em'

  8. #8
    L Carlson's Avatar
    Join Date
    Aug 2007
    Location
    Bonita Springs, Florida, United States
    Posts
    7,118
    +1
    2
    Quote Originally Posted by bkweld View Post
    oh yeah, that's my thread. I've learned so much more about performance and mods by doing my own work (excluding my current predicament) from now on unless my engine blows up, I'll fix it myself. I'm just glad i didn't buy that stupid 5 year warranty, the hell w/em'
    Thank You for the post Had to copy it a gain for Chris to re read. Thanks Lee One day the wax will fall out of his ears

  9. #9
    Bounty Hunter Carlos Thomas's Avatar
    Join Date
    Jul 2007
    Location
    San Leandro, CA
    Posts
    1,401
    +1
    22
    I have had that same hose pop off twice. I have put on a better clamp. Red loctite might help too. It fills up fast.

  10. #10
    tysonfzr's Avatar
    Join Date
    Nov 2009
    Location
    johor bahru malaysia
    Posts
    621
    another thing to look out for is the flushing adaptor,the spring inside flushing adaptor came off n water rushing into the hull..riva crew saw my post n send a new flushing adaptor to me

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Problem with Riva Stage 2 SHO
    By American pSycHO in forum Yamaha PWC Performance (4-stroke)
    Replies: 3
    Last Post: 08-23-2010, 07:42 AM
  2. buzz noise with riva ic
    By jusloungin in forum Yamaha PWC Performance (4-stroke)
    Replies: 38
    Last Post: 06-30-2010, 11:22 PM
  3. Performace problems with RIVA Stage 1 Kit
    By iceman1998 in forum 4-Tec Performance
    Replies: 4
    Last Post: 06-03-2009, 05:57 AM
  4. Any problems with Riva exhaust with Stage3?
    By camar0 in forum 4-Tec Performance
    Replies: 3
    Last Post: 09-05-2008, 09:20 AM
  5. Anyone have problems with riva IC Plumbing?
    By psycho rxp in forum 4-Tec Performance
    Replies: 26
    Last Post: 04-06-2006, 09:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •