Results 1 to 3 of 3
  1. #1

    Help missing 500 rpm!!!

    Stock 07 215 with riva washers/ slip was at 110in-lbs at zero hrs. Have 11 hrs now and this thing only rev's 7500rpm air temp 25 celcius can my slip be to low now or tps need adj.


  2. #2
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    Quote Originally Posted by coopersst View Post
    Stock 07 215 with riva washers/ slip was at 110in-lbs at zero hrs. Have 11 hrs now and this thing only rev's 7500rpm air temp 25 celcius can my slip be to low now or tps need adj.
    I would definitely pull the charger, and see where the slip is!

  3. #3
    Ok thanks i'll try that first i'm running 07 shaft set up with stock spring washers, maybe time to buy some mcmaster washers?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Missing 500 rpm + rusty spark plugs = stock intercooler leak
    By Dan_FZR in forum Yamaha PWC Performance (4-stroke)
    Replies: 6
    Last Post: 03-21-2011, 05:27 PM
  2. help me anticipate rpm with rude
    By BoostedH23a1 in forum 4-Tec Performance
    Replies: 3
    Last Post: 04-20-2008, 08:54 AM
  3. Help find lost RPM's.
    By Water4fire in forum 4-Tec Performance
    Replies: 43
    Last Post: 10-16-2007, 10:45 AM
  4. 400-500 Rpm??
    By Brueskerxp06 in forum 4-Tec Performance
    Replies: 1
    Last Post: 05-31-2007, 07:00 AM
  5. Replies: 1
    Last Post: 05-18-2005, 07:49 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •