Results 1 to 1 of 1

Thread: FX140 Fuel Pump

  1. #1

    FX140 Fuel Pump

    03 FX140 Cruiser. ran all day fine, turned it off. after a couple of minutes tried to restart. Turned over but would not fire.
    After getting it home I checked for spark and fuel. Spark all good but I could not hear the fuel pump running. Connected yamaha diagnostic software to force pump on. Pump would not start. Removed fuel sender unit to find one of the electrical pins on top of the pump unit broken off due to corrosion.
    Now I know Yamaha only sell the complete unit but surely someone has sourced an alternative supplier for the pump unit on it own.
    All help appreciated.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	DSC02345.JPG 
Views:	61 
Size:	57.3 KB 
ID:	210750   Click image for larger version. 

Name:	DSC02347.JPG 
Views:	57 
Size:	57.5 KB 
ID:	210751   Click image for larger version. 

Name:	DSC02346.JPG 
Views:	58 
Size:	58.1 KB 
ID:	210752  


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Fuel pump
    By bobscott in forum 4-Tec Performance
    Replies: 10
    Last Post: 06-15-2017, 04:26 PM
  2. Fuel pump mod
    By Mark-UK in forum Polaris How To & FAQs
    Replies: 18
    Last Post: 09-08-2009, 06:13 PM
  3. sl650 Fuel pump
    By gerhand44 in forum Polaris Open Discussion
    Replies: 3
    Last Post: 09-12-2006, 04:49 PM
  4. Fuel pump in gp1300r not working?
    By wildman326 in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 05-20-2006, 08:54 PM
  5. Performance Fuel Pump,is it needed for stage2?
    By novice_4 in forum 4-Tec Performance
    Replies: 2
    Last Post: 05-03-2006, 10:06 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •