Results 1 to 6 of 6
  1. #1
    jcjw1998's Avatar
    Join Date
    Aug 2010
    Location
    Dallas, TX
    Posts
    13

    Need help with SLX 785 Pro

    Hello everyone, I am new to the site and this is my first post. I just bought a 97 SLX pro 785 and looks like I got a bad deal. The ski runs great on the trailer but will not run at all on the water. It will start but once I throttle it, it just falls on its face and sputters. I took it to one of only a couple of people in the Dallas,Tx area that would work on the thing and he rebuilt the carb but still does the same thing. The mechanic can't seem to diagnose what is going on. The motor has good compression in all cyls and as mentioned the carb was rebuilt along with all new gas lines. Has anyone else experienced this problem and if so what do I need to do to repair it?

    Any help would be greatly appreciated.


  2. #2
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,327
    +1
    29
    Welcome to the Hulk.

    I had a similar experience and found it to be a bad spark plug.

    Make sure you're getting good spark to all 3 cyls.

    Are all the cyls warm when you touch them after running on the trailer?

  3. #3
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    Welcome to the Hulk.

  4. #4
    Derwood98's Avatar
    Join Date
    Jul 2010
    Location
    Lakeville, Minnesota, United States
    Posts
    627
    +1
    10
    Welcome. Are your exhaust valves opening and closing when on the trailer? Plugs are cheep. If in doubt, change them. Did he rebuild all three carbs or just one? Any idea on how many turns your jet screws are turned out?

  5. #5
    Well....I can't help but I am having the same problem with my 1997 SLT780. Rebuilt everything. Ran great for few hours. Starts and runs now but sputters and misses once under load. I believe it's electrical but I have no way of testing it.

  6. #6
    Derwood98's Avatar
    Join Date
    Jul 2010
    Location
    Lakeville, Minnesota, United States
    Posts
    627
    +1
    10
    Welcome to the Hulk. The best thing to do is start your own problem thread, describe you situation, background information and see where it goes.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need help with a built pro 12.
    By blairwill4 in forum Polaris How To & FAQs
    Replies: 17
    Last Post: 06-10-2015, 06:02 PM
  2. Need Help with Pro 785!!
    By Gunner-one in forum Polaris PWC Performance
    Replies: 4
    Last Post: 01-20-2014, 07:27 AM
  3. 785 pro, need help with carb tuning
    By billybobtucson in forum Polaris PWC Performance
    Replies: 12
    Last Post: 10-01-2009, 01:21 PM
  4. Please help with tuning a PRO 785
    By princy83 in forum Polaris Open Discussion
    Replies: 1
    Last Post: 06-29-2009, 10:56 AM
  5. Need help with pro cdi
    By Rodneyae in forum Polaris Open Discussion
    Replies: 15
    Last Post: 05-24-2007, 07:35 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •