Results 1 to 2 of 2
  1. #1

    overheating light and shut off gp1200 on start up

    hey guys i bought a 2001 gp1200 and was all excited to ride it. we took it up to Lake George and the thing starts then the overheating light comes on and the ski dies..The previous owner did some work to it and i know it has a d-plate with the chip..my next guess is the temp sensor by the exhaust because it isn't running long enough to really be overheating..it beeps 5 seconds after you start it up..then if you reset it it beeps again then dies shortly after...any help is appreciated because im debating whether to sell it and take the lost..thanks


  2. #2
    also tried to see if it was the cold temp sensor so when it was beeping i disconnected the blue plug under storage..it stopped going constant and the warning light started flashing as did the beeping before going constant again.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2001 Virage only runs on water for about 200 yards and shuts off
    By bbritton29 in forum Polaris Open Discussion
    Replies: 47
    Last Post: 06-02-2015, 01:17 PM
  2. Wave Venure 760 won't idle and shuts off randomly
    By wrnchman in forum Yamaha PWC Performance (2-stroke)
    Replies: 9
    Last Post: 09-28-2012, 01:54 PM
  3. Replies: 1
    Last Post: 11-24-2010, 05:38 PM
  4. 02 GTXDI runs a few seconds and shuts off
    By kaveman in forum 2-Stroke Performance
    Replies: 11
    Last Post: 08-05-2009, 07:51 PM
  5. ? about installing shut off valve on GTX RFI (diagram included)
    By jdy2kgt in forum 2-Stroke Performance
    Replies: 4
    Last Post: 06-22-2009, 08:57 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •