Results 1 to 5 of 5
  1. #1
    jdogfunk's Avatar
    Join Date
    Aug 2010
    Location
    Chicago, Il
    Posts
    23

    1995 Polaris SLX surging

    ok here is the run down i have a polaris slx that i recently started working on, today i just got the display to work. It was in limp mode. I disconnected the grey wires and now it gets moving, but now it surges. what could be the problem?
    the last run. i was going 50 mph at 5950 rpm.


  2. #2
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,329
    +1
    30
    WOT surging?

    Most likely carbs.

    I wouldn't keep riding it like that.....

  3. #3
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,584
    +1
    1,272
    What is the cause of your limp mode (RPM limiting)?

    Disconnecting the gray wire is simply a diagnostic to confirm that the engine is being electronically limited. It is NOT a fix for anything.

    Now that you know the limiter is being invoked, you need to figure out why.

    Low Oil, Low Fuel, overheat sensor?

  4. #4
    jdogfunk's Avatar
    Join Date
    Aug 2010
    Location
    Chicago, Il
    Posts
    23
    the display reads oil fuel hot. but it has oil and fuel. and its not hot. it only surges at wot.

  5. #5
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,584
    +1
    1,272
    Quote Originally Posted by jdogfunk View Post
    the display reads oil fuel hot. but it has oil and fuel. and its not hot.

    it only surges at wot.
    The MFD display shows all three warnings?

    Sounds like the MFD has a problem, or the wiring has a problem. Sometimes the fuel float will get heavy, and always read Low Fuel. That can be fixed with a replacement fuel float.

    The HOT and Low Oil warnings are not common unless the oil sender or temp sender have a problem.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FS 1995 Polaris SLX 780 - For Parts or Rebuild - $500 obo - Chicago
    By chicagoanalog in forum Polaris Skis
    Replies: 3
    Last Post: 07-04-2012, 03:45 PM
  2. 1995 Polaris SLX 780 smokes a lot - excess oil flow?
    By jdogfunk in forum Polaris Open Discussion
    Replies: 6
    Last Post: 06-30-2011, 09:35 PM
  3. 1995 polaris slx burnt up ground wire
    By tonyg12678 in forum Polaris How To & FAQs
    Replies: 1
    Last Post: 04-06-2011, 11:08 AM
  4. WTB WTB 1995 Polaris SLX 780 DRIVE SHAFT
    By koryk in forum Polaris Classifieds
    Replies: 2
    Last Post: 04-17-2010, 09:43 AM
  5. Parting out 1995 Polaris SLX 780
    By cubsfan2516 in forum Polaris Classifieds
    Replies: 39
    Last Post: 02-28-2009, 02:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •