Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1
    Davis151's Avatar
    Join Date
    Jul 2010
    Location
    San Diego, CA
    Posts
    33

    2 pump questions...

    Hey all...

    I have 2 quick pump questions, ski is a 2002 GTX 4-Tec

    So I recently had some pump work done (new impellar, wear ring, bearings and seals), took it out for a few hours and all seems well at the lake... but

    1) The pump still rattles when its on the hose, mechanic said their is no anti-rattle spring in the cone and the schematic I looked at does not list one.
    So should it have one, does it need an after-market one, should it rattle, etc.??

    2) The mechanic that did my pump said he packed all the bearings and the cone with Maxima waterproof grease... but everything I've seen is a heavy weight oil.
    Does this work as well, or could it be harmful, or run then change it ??

    Thanks a lot, I appreciate any adivce.


  2. #2
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    I don't believe the anti-rattle cones were ever used on the 4-tec pumps... at least not in the 04 and up models. That was a 2 stroke thing. The 4-tec pumps use grease from the factory... not oil. You should be just fine with your pump... as the rattle when on the hose is completely normal.

  3. #3
    Banned User
    Join Date
    Aug 2009
    Location
    Discovery Bay, CA
    Posts
    3,048
    +1
    336
    Quote Originally Posted by BigDaddyRXP View Post
    I don't believe the anti-rattle cones were ever used on the 4-tec pumps... at least not in the 04 and up models. That was a 2 stroke thing. The 4-tec pumps use grease from the factory... not oil. You should be just fine with your pump... as the rattle when on the hose is completely normal.
    +1 also bigdaddy could you please post on every current thread so as i browse through all the new ones i can check your avatar out... thanks in advance
    mike

  4. #4
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    I'll try

  5. #5
    Davis151's Avatar
    Join Date
    Jul 2010
    Location
    San Diego, CA
    Posts
    33

    Thumbs up

    I second the avatar posting.... Thanx for the info, guess I am good for the river.

  6. #6
    Davis151's Avatar
    Join Date
    Jul 2010
    Location
    San Diego, CA
    Posts
    33
    Quote Originally Posted by BigDaddyRXP View Post
    The 4-tec pumps use grease from the factory... not oil.

    Out of curiosity... Why is it that GTX pumps are loaded with grease where as all others here are filled with oil

  7. #7
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    Quote Originally Posted by Davis151 View Post
    Out of curiosity... Why is it that GTX pumps are loaded with grease where as all others here are filled with oil
    All 4-tec pumps come from the factory with grease... not just the GTX.

  8. #8
    Davis151's Avatar
    Join Date
    Jul 2010
    Location
    San Diego, CA
    Posts
    33
    Quote Originally Posted by BigDaddyRXP View Post
    All 4-tec pumps come from the factory with grease... not just the GTX.
    Ah, ok. Sorry for noob questions, but I am.. loll. So what are the advantages to switching to filling with pump oil.

    Also, how many hours should you empty and refill the pumps, and if so, what oils are best? I've been fond of Klotz fluids in my KTM bikes.

  9. #9
    Davis151's Avatar
    Join Date
    Jul 2010
    Location
    San Diego, CA
    Posts
    33
    Bueller..... anyone, anyone

  10. #10
    outboard john's Avatar
    Join Date
    Jun 2006
    Location
    Escondido, Ca.
    Posts
    474
    +1
    2
    No Guru here, but I have had the pump apart many times, stainless wear ring, upgrade/tweak impellers etc. and all Iv'e ever done is add a little grease to what's already there just to make up for the bit that is lost during disassembly. I only have 80 Hrs on my 05 RXP though.

    OBJ

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Bilge Pump Questions
    By Piney in forum Sea Doo Open Discussion
    Replies: 20
    Last Post: 03-18-2006, 09:33 AM
  2. more pump questions
    By chip in forum Yamaha Open Discussion
    Replies: 4
    Last Post: 02-25-2006, 08:00 PM
  3. Island racing and 05 pump question ??
    By slow1300 in forum Yamaha PWC Performance (2-stroke)
    Replies: 12
    Last Post: 02-17-2006, 12:27 AM
  4. pump question
    By rxpblast in forum 4-Tec Performance
    Replies: 6
    Last Post: 01-11-2006, 09:37 PM
  5. pump question
    By skillet in forum 4-Tec Performance
    Replies: 16
    Last Post: 01-06-2006, 11:41 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •