Results 1 to 6 of 6
  1. #1

    Angry 2000 genesis ficht cant get 83 82 81 cides out of machine

    ok i installed the old capacitor into the machine i checked the voltage drop after learning it from this forum. the running voltage was right around 42 volts. when checking the capacitor after shutting off the machine the cap voltage dropped about 1 -2 volts per second at least. is this normal?? i fired it back up and got check engine light again and 83 82 81 codes again i had just erased codes prior to running and had a code 11. any sugestions where i should go next?? thanks for your help.


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,570
    +1
    1,272
    Injector voltage sag as you described is normal - multiple seconds to drop from full voltage towards zero volts after engine shut down. Sounds like the big capacitor is fine.

    Since you have previously confirmed the ignition coil grounding is good, and the EMM wire harness grounding is good, my guess is that the EMM needs service.

  3. #3
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    6,515
    +1
    1,260

    codes 81,82,83

    I pretty much had the same thing..couldn't get these codes to clear, but I never saw a code 11 out of this emm after numerous resets. It's said that in some cases, only podiag can reset the codes..it has a problem methinks with the regulator rectifier section of the board. I t did throw an a/c overvoltage and a phantom code for a temp sensor issue. It's been sent off for repair..so I guess we'll be back here to compare note son the repairs.

    Shame they built them this way..an external regulator would have made more sense for maintenance, but no doubt the designers wanted to be in complete control of the power system ( I can see that line of thinking too)

    pretty sure this one is a 2002

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,570
    +1
    1,272
    When using the LED tool to read the EMM codes, 11 means 'no stored codes'.

    Regarding this 2000 Genesis, I think what is happening is that the EMM codes do indeed clear, and it then reads out code 11, UNTIL the engine is next run, when the 8x codes reoccur.

  5. #5
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    6,515
    +1
    1,260

    codes 81-82-83

    well the boys at dfi told me told me today that those are surely codes indicating that the emm needs repair.

    Had a bit of a laugh too..they also told me the mx 140 emm I sent in had reported an overheating code 175 times! I assume that el cheapo battery they had in there was making the regulator work overtime. ( it dutifully reported a code 25 ( emmm overheat))

    as we're always saying, a pwc deserves the best battery you can afford...and you should make it a point to afford a really good one.

    this emm had plenty of waterflow..but obvioulsy not enough when you ask the charging system to put out 200% every time the boat is started up. I guess this localized hot spot isn't directly in the wtaer flow...

    I'll be watching the charging system on this on really close when I get the computer back.

  6. #6
    thanks for the replys i have not confirmed yet that the emm ground is good.what i did is removed all the coils from the coil block cleaned all the terminals and reinstalled. i also took a jumper wire from the main ground on the engine block and grounded it to the coil block under one of the coil grounds on the end that touch the coil plate. but as far as the emm ground what should i do?? thanks again you guys for all of your help.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. WTB - Parts riva nozzle rings 83,82,81
    By MILLER PHASE 3 1050 in forum Sea Doo Classifieds
    Replies: 1
    Last Post: 07-01-2013, 09:53 AM
  2. 2000 Genesis Ficht - problem/question.
    By rjcapo02 in forum Polaris How To & FAQs
    Replies: 4
    Last Post: 07-25-2012, 09:09 PM
  3. 2000 Genesis Ficht...Idle restricted to 2000RPM. Tech says bad EMM.
    By cfellers1 in forum Polaris Open Discussion
    Replies: 4
    Last Post: 08-25-2010, 07:46 PM
  4. 2000 genesis ficht codes 81 82 83 please help!!
    By rspray in forum Polaris Open Discussion
    Replies: 1
    Last Post: 08-15-2010, 11:19 AM
  5. 2000 genesis ficht wont rev up above idle please help!!
    By rspray in forum Polaris Open Discussion
    Replies: 7
    Last Post: 08-11-2010, 02:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •