Results 1 to 4 of 4
  1. #1

    jet pump engine allignment woes

    hey guys 93 sl 750 trying to get this thing alligned correctly...the coupler is too high, there are no shims on the pto end engine mounts above or below the rubber puck, the pitch seems to be right on so shimming the mag end mounts won't work. do i have to take the engine out and grind the mount plate on the pto end or can something be done with the pto end motor mounts themselves?


  2. #2
    johnsonmtz's Avatar
    Join Date
    Oct 2006
    Location
    Mt. Zion Illinois
    Posts
    1,250
    +1
    7
    Hmm, are there possibly washers between the motor mounts and the bosses in the hull?

    How much is the "too high" that we're talking about? A couple of SS fender washers stacked between the motor mount and the bed plate on hte MAG end will
    make major changes on the PTO end. I'd suggest you throw a single washer in the front and see where you stand.

    KJ

  3. #3
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,570
    +1
    1,272
    Quote Originally Posted by xltsp8 View Post
    hey guys 93 sl 750 trying to get this thing aligned correctly...the coupler is too high,

    there are no shims on the PTO end engine mounts above or below the rubber puck, the pitch seems to be right on so shimming the MAG end mounts won't work...
    How are you checking the alignment? With an alignment tool?

    Is the through-hull bearing in place? Sometimes the through-hull assembly can push the shaft around. Remove it while checking alignment with the alignment tool.

    The rubber hose mounted through-hull bearing must align with the drive shaft AFTER the shaft/engine alignment is checked (and corrected if need be).

    Do you still have the original 1993 non-modular 146mm jet pump installed?
    If yes, now might be a good time to upgrade to the better 1994+ modular 148mm jet pump (with a 148mm SL750 impeller). The 148mm jet pump is more efficient, so more thrust from the same engine power.

  4. #4
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,327
    +1
    29
    In extreme cases, I have had to grind the engine plate a little bit.

    And if that didn't work, then I installed a washer between the top of the pump and hull. (1 washer at the top should do it. The large O ring should still seal fine with a 1/16" washer shim)

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Which jet pump, which engine? SL750, SLT 780
    By Dirty_Jon in forum Polaris Open Discussion
    Replies: 28
    Last Post: 05-04-2015, 10:18 PM
  2. Try to find engine and jet pump dimensions? Please give me yours!
    By Jan E. in forum Conversion PWC Performance Skis
    Replies: 4
    Last Post: 08-17-2014, 02:55 PM
  3. Seadoo Speedster engine swap/jet pump
    By Morten1988 in forum Sea Doo Sport Boats
    Replies: 3
    Last Post: 06-28-2014, 11:08 AM
  4. Twin jet pumps driven off one engine?
    By turbotank in forum Conversion PWC Performance Skis
    Replies: 9
    Last Post: 10-23-2012, 05:55 AM
  5. 2001 virage engine and jet pump removal
    By jeeprunnr in forum Polaris How To & FAQs
    Replies: 6
    Last Post: 12-08-2006, 09:26 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •