Results 1 to 2 of 2
  1. #1

    Join Date
    Jul 2010
    Location
    Sayreville, nj
    Posts
    55

    97 zxi1100 impeller question or quite possibly a sbt horror story

    I sent my impeller to sbt to be refurbished. I finally get it back and install it to find that there is about 3/16" between the impeller and wear ring. I thought the impeller was supposed to have a few thousandths of an inch tolerance, not 3/16".
    Did sbt screw up? Did they send me the wrong one? I don't think this is normal.


  2. #2
    PEVO's Avatar
    Join Date
    Mar 2009
    Location
    central Tx.
    Posts
    85
    Duh...You need like almost -0-clearence. Yes someone fuked up...CALL SBT right away.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Riva or R&D RXP 215 supercharger impeller question
    By MarineBoy in forum 4-Tec Performance
    Replies: 5
    Last Post: 08-27-2012, 09:19 AM
  2. riva stage one and stage 2 impeller question
    By CarFanatic in forum 4-Tec Performance
    Replies: 6
    Last Post: 06-19-2006, 09:31 PM
  3. (impeller)new or rebuild?????
    By buddydoo in forum 4-Tec Performance
    Replies: 5
    Last Post: 01-02-2006, 02:06 PM
  4. Stupid question...or not??
    By RustySeaRustyDoo in forum Sea Doo Open Discussion
    Replies: 13
    Last Post: 11-17-2005, 01:40 AM
  5. Solas impeller question
    By Jeff C in forum 4-Tec Performance
    Replies: 6
    Last Post: 08-03-2005, 11:41 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •