Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1

    "02 Virage TXI fuel issue

    Hello all
    I had an issue with my Virage, didn't have time to get into it so I took it to a shop. I had an idea that the regulator may have fell off after reading several threads on here. Well they checked the fuel pressure and found in fact it was low, took everything apart and found the regulator did come off. Now I just call a call that they "bench" tested my fuel pump before putting everything together and found it had little to no pressure. I'm not familiar with this but could this happen? Pump was reading around 30 psi with the return line clamped off last week- that is what he told me, now pump is not working??? Has anyone heard of this before?


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,593
    +1
    1,275
    Anything is possible, of course. While repairing the regulator, it is possible to manhandle the electrical wires or the electric pump itself enough to break something. Or it could just have been ready to fail next, regardless of who touched it.

    Both new and used complete Ficht fuel pumps are available.

  3. #3
    Thanks, I guess if it was going to happen better to happen now rather than after everything is put back together. Where is a good place to get a new pump?

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,593
    +1
    1,275
    Quote Originally Posted by daddyjn View Post
    Thanks, I guess if it was going to happen better to happen now rather than after everything is put back together. Where is a good place to get a new pump?
    Parts Sources can be found in my signature links

  5. #5
    Ok, I'm back. Got it back and took it out now it cuts out when it is WOT, could it be the TPS? Is so how do I test it to see.
    Thanks
    Jerry

  6. #6
    Nevermind I found how to check it, just didn't search enough.

  7. #7
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,593
    +1
    1,275
    Quote Originally Posted by daddyjn View Post
    ...Got it back and took it out now it cuts out when it is WOT, could it be the TPS? If so how do I test it to see.
    Thanks
    Jerry
    Fuel pressure checked, and is now correct?

    There is no reliable test for a TPS, other than installing another new or known good TPS.

    Does it restart immediately after it shuts down?

    Will it run happily at medium throttle levels?

    Any warning message or red lamp on the display?

  8. #8
    Fuel pressure is reading fine.
    Starts right up.
    Medium to about 3/4 runs fine- only when I pin the throttle-
    No lights or messages.

    When I first put it in the water after the repair if cut out a little at medium throttle, but he said it might, air??? It smoothed right out and ran fine. I took it easy for about 30 minutes, then eased it up til I got to full throttle about an hour total- I didn't want to get to far out incase something was wrong.

    Didn't seem to give an issue right away. Shut it down for awhile when I got back on it and took it out I noticed the issue, at full it cuts out a bit, I back of a little and it takes right off. Only seems to have an issue when I pin it.
    Thanks
    Jerry

  9. #9
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,593
    +1
    1,275
    Could be the TPS.

    I would change it out. If the problem goes away, that is good.

    If the problem isn't fixed, you will have a spare TPS, which is a good thing to have.

  10. #10
    Watcon's Avatar
    Join Date
    Oct 2005
    Location
    Seattle WA
    Posts
    872
    I would agree on the TPS possibility.. A minor exhast leak will do this also.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 02 Virage TXI bogging and fuel pressure
    By 48Straight in forum Polaris Open Discussion
    Replies: 21
    Last Post: 07-09-2016, 10:22 AM
  2. Fuel pump question- 02 Virage txi
    By daddyjn in forum Polaris Open Discussion
    Replies: 17
    Last Post: 07-28-2015, 03:39 PM
  3. '02 Virage TXI fuel leak
    By daddyjn in forum Polaris How To & FAQs
    Replies: 4
    Last Post: 07-07-2014, 12:46 PM
  4. 02 Virage TXi fuel pump removal
    By Bigbill55 in forum Polaris Open Discussion
    Replies: 3
    Last Post: 03-25-2012, 04:16 PM
  5. 02 polaris virage txi fuel pump
    By rickybobby in forum Polaris Open Discussion
    Replies: 12
    Last Post: 03-18-2011, 03:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •