Results 1 to 8 of 8
  1. #1

    Please help 1993 Polaris SL 750 Problems

    Hello, m new o he forum, ive been reading a lot but no writing.

    i need help!!! Here is the problem, my 750 starts and idles no problem. I give it gas it bogs out. So far ive changed the gas, rebuilt the fuel pump, changed the reeds, cleaned the carbs, changed all the fuel lines, added a restrictor, new gas tank fittings, re sealed he selector. Pop off test is 18 # compression is 120 all 3 cylinders. no air in fuel lines either.

    basically the fuel sysem has been completely re built.

    please help im going nuts here. no clue whats wrong.

    any advice will be greatly appreciated. Thanks


  2. #2
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    Welcome to the Hulk.

    What is the condition of the jet-pump?
    Do you have good clean spark?
    When was the last time it run correctly?

  3. #3
    jet pump spins freely. Ran well ill August last year. when running if i pull the choke then give it gas it will take off but bog down just as i reach plane. spark seems to be good, i can see it from all the plugs

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,584
    +1
    1,272
    Welcome to the Hulk

    You took the carbs apart and rebuilt them - correct?

    Carb adjustment screws are now set correctly for your model and year?

    Correct spark plugs installed?

    Spark plug wires trimmed back 1/4 inch and re-screwed into the plug caps?

    Review how the fuel hoses are connected, especially at the carbs, sometimes we all make mistakes.
    Did you install a 3 outlet fuel pump?

  5. #5
    never rebuilt the carbs, just cleaned everything up, still using the original fuel pump.
    Plugs and wires are all correct. ill check the hoses again

    Thanks

  6. #6
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,584
    +1
    1,272
    Quote Originally Posted by sandylowlead View Post
    never rebuilt the carbs, just cleaned everything up, still using the original fuel pump.

    Plugs and wires are all correct. I'll check the hoses again...
    Well, that would be the job to do next. Rebuild those carbs.

    Polaris specific Mikuni carburetor rebuild kits are available from John Zigler, contact info in my signature links under Parts Sources.

    Get a triple outlet Fuji fuel pump while you are talking to him.

  7. #7
    Thank,

    I didnt hink i needed too since he pop off was correct. I tossed around the new pump but i though he rebuild would be good.

  8. #8
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,584
    +1
    1,272
    Quote Originally Posted by sandylowlead View Post
    ...I didn't think I needed to since the pop off was correct.

    I tossed around the new pump but i though he rebuild would be good.
    Pop off pressure check doesn't tell you whether the carbs are dirty or clean inside.

    With the age of these machines, they ALL should have the carbs off for a rebuild and internal cleaning and check-up.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1994 Polaris SL 750 problems... again.
    By pdarling20 in forum Polaris Tech Tips and Info
    Replies: 2
    Last Post: 09-16-2013, 01:55 PM
  2. 1993 Polaris SL 750 Questions
    By Djb0127 in forum Polaris Open Discussion
    Replies: 5
    Last Post: 05-22-2012, 04:22 PM
  3. 1993 polaris SL 750 stalling at idle
    By Johnny H. in forum Polaris Open Discussion
    Replies: 2
    Last Post: 05-27-2011, 09:06 PM
  4. 1993 Polaris SL 750 Exhaust Replacement
    By lakeskier in forum Polaris Projects
    Replies: 0
    Last Post: 07-16-2009, 08:25 PM
  5. 1994 Polaris SL 750 problem
    By Playtime in forum Polaris Open Discussion
    Replies: 5
    Last Post: 04-24-2007, 06:49 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •