Results 1 to 2 of 2
  1. #1

    Join Date
    Jun 2010
    Pittsburgh, PA

    Spx Starting issues

    This has not been our summer for our ski's. We finally thought they were both running great and it didn't last long. On our 99 SPX, when we go to start we get the two beeps and hit start and nothing. The start button makes a click notice but nothing else. Give it gas, nothing. We changed the fuel, the battery is good, we are not sure what else to check? What do you suggest? We called the shop and they can't do anything till at least next week. This week was our last trip of the summer to the water, so taht doesn't work. Anyway to get it running to get us through this weekend?

  2. #2
    New starter. Check both red and ground leads to your starter. Check starter solenoid.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 98 GP1200 Starting and Running Issues
    By renee in forum Yamaha Old School Skis
    Replies: 14
    Last Post: 07-09-2008, 08:49 AM
  2. 96 spx
    By jimski in forum Sea Doo Classifieds
    Replies: 0
    Last Post: 05-15-2008, 04:54 PM
  3. Virage I 2002 Starting Issues
    By fbsmith in forum Polaris How To & FAQs
    Replies: 5
    Last Post: 04-14-2008, 11:22 AM
  4. Replies: 16
    Last Post: 05-30-2007, 01:49 PM
  5. 96XP starting issues...
    By KeithKman in forum 2-Stroke Performance
    Replies: 3
    Last Post: 01-04-2007, 11:01 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts