Results 1 to 3 of 3
  1. #1

    Join Date
    Jul 2005
    Location
    Buffalo, in the State of Taxation
    Posts
    40

    Gots a short I think....need help on a 4TEC SC

    OK....2003 4TEC SC, slightly modded (LVL1), never had a battery issue till this year.

    Oh...BTW, early this summer for the first time ever the ski was tipped over (Fresh water & definately water in the hull). Took a few minutes to get everyone settled & turn it back over. Started right up & has run perfectly......until about a month ago.

    HAd a relatively new (<1 year old) sealed battery in it & went to go out one day after it had sat a couple weeks & nothing.

    Took it back, they said it was cooked & there was something wrong (a short) with the PWC. I said bull$hit, FU & some other stuff & left. Went & bought a new Interstate battery.

    Used it a couple/3 times, then its' sat about 2-3 weeks again. Just went out to put the trickle charger on it & it doesn't register ANYTHING. Tried to start it & DEAD. Battery is cooked. While the charger was on it (2 amp charging settin) I could hear a regular click in the engine compartment about every 30-40 seconds or so. Almost sounded like the solenoid engaging but I cannot be sure.

    Any idea's where I might begin to look before I take it to my local Stealer? thx


  2. #2

    Join Date
    Jan 2008
    Location
    Canada
    Posts
    226
    Quote Originally Posted by jitees View Post
    OK....2003 4TEC SC, slightly modded (LVL1), never had a battery issue till this year.

    Oh...BTW, early this summer for the first time ever the ski was tipped over (Fresh water & definately water in the hull). Took a few minutes to get everyone settled & turn it back over. Started right up & has run perfectly......until about a month ago.

    HAd a relatively new (<1 year old) sealed battery in it & went to go out one day after it had sat a couple weeks & nothing.

    Took it back, they said it was cooked & there was something wrong (a short) with the PWC. I said bull$hit, FU & some other stuff & left. Went & bought a new Interstate battery.

    Used it a couple/3 times, then its' sat about 2-3 weeks again. Just went out to put the trickle charger on it & it doesn't register ANYTHING. Tried to start it & DEAD. Battery is cooked. While the charger was on it (2 amp charging settin) I could hear a regular click in the engine compartment about every 30-40 seconds or so. Almost sounded like the solenoid engaging but I cannot be sure.

    Any idea's where I might begin to look before I take it to my local Stealer? thx
    I think something got wet in the electronics and shorted the system out. Who can say what it is without an inspection. Sounds like your dealer diagnosed the problem correctly the first time. Now you are out 2 batteries (instead of just one).

    You might try disconnecting the solenoid and cleaning it. Check for burnt contact points. It is an inexpensive part and with the clicking you describe is a reasonable place to start if you don't want to take it to the dealer. I'd make sure you know what the problem is before you connect battery number 3. Maybe you can meter the system to see if there is a short to ground (before reinstalling a new battery).

  3. #3
    NetBret's Avatar
    Join Date
    Mar 2010
    Location
    Daytona Beach, FL
    Posts
    36
    Hey Jitees, I've got a similar problem...were you able to fix the problem?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. guys, I really need help on this one
    By maguyver in forum Yamaha Old School Skis
    Replies: 19
    Last Post: 02-11-2008, 10:08 PM
  2. Need Help on 02 virage 700cc
    By jeffholloway96 in forum Polaris How To & FAQs
    Replies: 13
    Last Post: 12-19-2007, 07:48 AM
  3. Need help on a 440!!
    By thesepaperwings in forum Kawasaki Open Discussion
    Replies: 1
    Last Post: 11-15-2007, 08:36 AM
  4. Need Help On Motor Mounds
    By wsony13 in forum Polaris Open Discussion
    Replies: 4
    Last Post: 08-26-2007, 10:54 PM
  5. Replies: 11
    Last Post: 08-25-2006, 06:43 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •