Results 1 to 4 of 4
  1. #1

    '97 STX Jet Pump No Thrust

    Just bought a 1997 STX 900 with a recently rebuilt engine. The engine runs fine, but there is barely any thrust. The previous owner had an aftermarket impeller installed for low end thrust for wakeboarding. The engine revs to max but goes a max of 15 mph. Sometimes the engine stops suddenly mid throttle. Looking at the jet pump from the back, I noticed the shaft coming out of the impeller is resting on the housing and is loose and it is missing the pointed cap at the end. See pic. Can anybody tell me what parts I might need to fix the problem?

    Thanks,

    Ditto
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	photo.jpg 
Views:	59 
Size:	119.8 KB 
ID:	211995  


  2. #2
    PEVO's Avatar
    Join Date
    Mar 2009
    Location
    central Tx.
    Posts
    85
    wow! time to start looking for a whole pump unit. Yes there should be a end cone covering the exposed shaft. This cone also holds in place the "missing" rear bearing the supports the impeller shaft. From what i can see damage-wise is a ruined impeller, impeller shaft(maybe) drive shaft(ruined splines...maybe) pump liner for sure. In other words LOTS of problems!

  3. #3
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    6,530
    +1
    1,281
    I'd be having a "chat" with the previous owner.... parts for these repairs are costly...and it's obvious that anything resembling routine maintenance was not practiced by the previous owner.

  4. #4
    PEVO's Avatar
    Join Date
    Mar 2009
    Location
    central Tx.
    Posts
    85
    Quote Originally Posted by nmpeter View Post
    anything resembling routine maintenance was not practiced by the previous owner.
    I'm sure it was Making one HELL OF A RACKET with the impeller just bouncing around inside the housing. I'm SURE the seller KNEW it was FUBAR before they sold it.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FS - Parts 97 XP jet pump
    By RossM in forum Sea Doo 2 Stroke Skis
    Replies: 1
    Last Post: 04-20-2015, 02:19 PM
  2. 1100 STX Jet Pump Mounting Bolts Torque Specs
    By cverscha in forum Kawasaki How To & FAQs
    Replies: 2
    Last Post: 08-09-2013, 12:01 PM
  3. stx jet pump repair
    By chariotracer in forum Kawasaki Open Discussion
    Replies: 2
    Last Post: 11-23-2009, 12:04 PM
  4. 97 GTX jet pump oil for bearings?
    By awague2 in forum 2-Stroke Performance
    Replies: 2
    Last Post: 06-30-2008, 11:35 AM
  5. SLTX 97 Polaris,jet pump problem
    By grifter in forum Polaris How To & FAQs
    Replies: 10
    Last Post: 05-24-2007, 03:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •