Page 1 of 5 1 2 3 ... LastLast
Results 1 to 10 of 48

Thread: Ouch!

  1. #1

    Join Date
    Oct 2007
    Location
    Brisbane, Australia
    Posts
    1,538
    +1
    3

    Ouch!

    See pic's.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	27082010191.jpg 
Views:	92 
Size:	131.9 KB 
ID:	212007   Click image for larger version. 

Name:	27082010194.jpg 
Views:	88 
Size:	98.7 KB 
ID:	212008   Click image for larger version. 

Name:	27082010193.jpg 
Views:	81 
Size:	98.6 KB 
ID:	212009   Click image for larger version. 

Name:	27082010195.jpg 
Views:	70 
Size:	62.5 KB 
ID:	212010  


  2. #2
    RichieFZR's Avatar
    Join Date
    Jan 2010
    Location
    Gold Coast, Queensland, Australia
    Posts
    2,093
    +1
    4
    Quote Originally Posted by Gunna View Post
    See pic's.
    OuCh! Who's is that???

  3. #3

    Join Date
    Oct 2007
    Location
    Brisbane, Australia
    Posts
    1,538
    +1
    3
    Quote Originally Posted by RichieFZR View Post
    OuCh! Who's is that???
    Mine

    Actually it was BigPig's motor from the Bridge to Bridge race earlier this year.

    I thought others would like another hard luck story.

  4. #4
    i will get all the rest i need when im dead corkycat's Avatar
    Join Date
    Jan 2009
    Location
    uk
    Posts
    840
    +1
    1
    ouch,,,looks like the rod broke?????? as there looks to be impact damage around where it finally broke through...
    on the plus side give you chance to do a turbo build now

  5. #5

    Join Date
    Oct 2007
    Location
    Brisbane, Australia
    Posts
    1,538
    +1
    3
    Quote Originally Posted by corkycat View Post
    ouch,,,looks like the rod broke?????? as there looks to be impact damage around where it finally broke through...
    on the plus side give you chance to do a turbo build now
    Nar, I'll pass on the turbo for this year now the ETC8 is sitting on the shelf.
    Rod snapped off the crank (loss of oil) and luckily only did that damage. I have some alloy welding people glueing the block back up next week. I'll share some pics of their handywork next week.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	Crank.jpg 
Views:	61 
Size:	48.7 KB 
ID:	212014  

  6. #6
    coldspace's Avatar
    Join Date
    Feb 2009
    Location
    Brisbane, Australia
    Posts
    438
    Yep mate, ouch and I'm winging about a couple of minor clutch failures,lol.

  7. #7
    Cold space what boost and rpm are you running with those clutch failures?

  8. #8

    Join Date
    Oct 2007
    Location
    Brisbane, Australia
    Posts
    1,538
    +1
    3
    Quote Originally Posted by miker1 View Post
    Cold space what boost and rpm are you running with those clutch failures?
    We think it's because he was using syn oil for a while rather than mineral oil. That wouldn't be helping much anyway.




    He wouldn't break it from riding too hard. He's a pussy!

  9. #9
    coldspace's Avatar
    Join Date
    Feb 2009
    Location
    Brisbane, Australia
    Posts
    438
    Quote Originally Posted by Gunna View Post
    We think it's because he was using syn oil for a while rather than mineral oil. That wouldn't be helping much anyway.




    He wouldn't break it from riding too hard. He's a pussy!

    Lol, I was been a pussy the second clutch failure so its definatly another issue, points to the syn oil. Will try new oil and a whole new clutch assembly in the next couple of weeks

  10. #10
    coldspace's Avatar
    Join Date
    Feb 2009
    Location
    Brisbane, Australia
    Posts
    438
    Quote Originally Posted by miker1 View Post
    Cold space what boost and rpm are you running with those clutch failures?
    Et low boost wheel at 13 psi at 8400, but the second failure was after a long off-shore distance ride so the ski hardly ran above 7500 rpm when backin the broad water it had a couple of WOT runs then it blew . It had syn oil in it since new and now 2 clutches in 4 hrs so will try again with mineral oil and change out the whole new assembly not just the sprag brake itself.

Page 1 of 5 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Ouch!
    By MikeTrin in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 04-28-2006, 10:06 PM
  2. OUCH!!!
    By Green Hulk in forum Sea Doo Open Discussion
    Replies: 10
    Last Post: 04-18-2006, 05:31 AM
  3. Ouch!
    By BDNJ in forum Videos & Pictures
    Replies: 8
    Last Post: 04-07-2006, 09:21 AM
  4. Fired my first flare just now...ouch
    By Shibby1485 in forum Sea Doo Open Discussion
    Replies: 7
    Last Post: 12-10-2005, 06:26 PM
  5. Reverse lever *$% OUCH$%$%
    By Sunfunzoom in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 08-08-2005, 11:55 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •