Results 1 to 6 of 6
  1. #1

    Join Date
    Aug 2009
    Location
    Dayton, Ohio
    Posts
    35
    +1
    1

    MSX 150; idle hunting, runs rich, 6000RPM max, 40mph max, sluggish - after a rollover

    I have a 2003 MSX 150 that was rolled over at low speed and righted by turning it over in the wrong direction and then rolled back over in the correct direction. (I guess they thought that would make everything OK!). I didn't find out till much later!!
    Anyway now it is sluggish, max RPM is 6000, max speed 42 mph, idle hunts.
    If you let off sharply on full acceleration you can hear the waste gate dump.

    There was oil all over in the hull, oil and water mixture in the intake and inner cooler, including the MAP and Pressure sensors. I cleaned them w/CRC electronic cleaner. The plugs were gas fouled as well as the O2 sensor. I did not take the inner cooler or the intake off. I just pulled the drain plug and sprayed cleaner thru them. Put new plugs in, changed the fuel and oil filters and the oil. (the oil level could possibly have been high). But all to no avail!!!!!

    I have followed an old tread w/similar symptoms. And have tried to follow the advice.
    I am confused by a post that refers to a DESPERADO post saying to replace the O2 and gives a new PN of 2410605 to buy one for a FSX snowmobile for $54 but the number for me comes back as the MAP sensor (now $84)! Does anybody have the correct PN for the O2 sensor (alt to the $300 one listed for PWC"s)

    Here is the post from 2008

    "Here is your answer:
    FROM DESPERADO's POST on another thread:
    >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

    The sensor is Bosch PN 0 261 230 042. Try your local Napa or Carquest stores.... you'll get these at 1/2 the above cost.....
    >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

    And here:

    While at your Polaris dealer, ask for PN 2410605......... that is the exact same sensor but used in Polaris FST snowmobiles...... dealer cost shows $54 for this sensor.

    It is sad to see Polaris charges so much more for PWC parts than the exact same parts used on the snowmobiles..... and I mean really the exact same part! I guess they want to be out of the PWC business asap by discouraging customers.....



    PLease help
    brunoski


  2. #2

    Join Date
    Feb 2008
    Location
    No. MN
    Posts
    320
    I have a spare MAP sensor and a spare O2 sensor for sale fairly cheap if you need them. Let me know.

  3. #3
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,599
    +1
    1,276
    I also have an O2 sensor available for sale

    O2 oxygen sensor 0451353 for Weber engine (MSX 110, MSX 150)


  4. #4

    Join Date
    Feb 2008
    Location
    No. MN
    Posts
    320
    It is my understanding that you usually need a re-set or re-flash after a roll over.

  5. #5
    desperado's Avatar
    Join Date
    Aug 2007
    Location
    Montreal, Canada
    Posts
    453
    +1
    3
    +1.

    Changing the O2 sensor and/or MAP sensor will be useless in this case. ECU memory needs a reset.... even though no codes are showing when connected to Digital Wrench.

  6. #6

    Join Date
    Apr 2011
    Location
    vancouver, bc
    Posts
    209
    +1
    13
    Quote Originally Posted by desperado View Post
    +1.

    Changing the O2 sensor and/or MAP sensor will be useless in this case. ECU memory needs a reset.... even though no codes are showing when connected to Digital Wrench.
    how to reset ecu memory in this case?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. '04 polaris MSX 150. Idle only now
    By brunoski in forum MSX/Matrix
    Replies: 12
    Last Post: 06-24-2016, 11:15 AM
  2. MSX 150 Will not run over 40
    By trn1977 in forum Polaris Open Discussion
    Replies: 4
    Last Post: 08-22-2013, 12:10 PM
  3. MSX 150 Will not run over 40
    By trn1977 in forum Polaris How To & FAQs
    Replies: 0
    Last Post: 08-17-2013, 11:01 AM
  4. Pair of MSX 150 wont stay running
    By FRITZ in forum Polaris Open Discussion
    Replies: 2
    Last Post: 07-01-2011, 09:29 PM
  5. Replies: 39
    Last Post: 09-16-2010, 09:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •