Results 1 to 5 of 5

Thread: Hydrilla

  1. #1

    Hydrilla

    I sucked some up when i went out today.......i wasnt paying attention and ended up in a big bed of that nasty crap....so i was right by my destantion where i was going and could see the boat i was going to.....so i kept starting it and trying to get as close to the edge of the bed as i could so i could get pulled out of that nasty shit....and get to the shore so i could clean it out.....anyway it cut off cause is said exhaust....and then beeped some and didnt start up once...im guessing that it was over heated....after i got pulled out and cleaned out and everything we were good at least i think so ..... its a 2008 rxt with 35 hours on it i was wondering if i could have done any damage...looks like a lil bit of oil in the hull oil level a lil low...just wondering if i messed it up bad or what?


  2. #2
    you mean over 40 views and not one person can give me there opinion such a supportive board i belong to..........i guess i will just stick to my lightning board

  3. #3
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    If all you did was overheat the exhaust then no,IMO you didnt tear anything up..Make sure all your waterways are clean and free of debris,Check your hoses and couplers for being melted or cracked do to the over heated condition. also check your carbon seal for any crackes or gouges in it....Then after you have given it a once over take it to the water and start it on the trailer and let it run for awhile to make sure it is all good before taking it back out on the water.....

  4. #4
    thanks for the reply....yeah i rode it about 45 minutes after it happened and i cleaned everything out no problem.....where is the carbon seal at? just curious and was wondering maybe about the wear ring on how to check what kind of condition thats it?!!?! thanks again

  5. #5
    YoYamma's Avatar
    Join Date
    Aug 2006
    Location
    Central Florida
    Posts
    21,528
    +1
    4,755
    Quote Originally Posted by eviiil View Post
    thanks for the reply....yeah i rode it about 45 minutes after it happened and i cleaned everything out no problem.....where is the carbon seal at? just curious and was wondering maybe about the wear ring on how to check what kind of condition thats it?!!?! thanks again
    If it ran for 45 minutes w/o any issues I would say you're probably okay. The rocks are usually more damaging than the weeds. The carbon seal is related to the drive shaft assembly; if it's not leaking, then DON'T screw with it. Like Snoman said, take it to the water, back it down the ramp and start it on the trailer and let it run; remove the seat, give it a little throttle and inspect for any water coming in near the shaft. As to the wear ring, that's a plastic sleeve around your impeller; they can be easily damaged by rocks and you will notice a loss in performance, but if your ski ran like normal then it's probably not an issue. Oh yeah, stay out of the weeds...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. '07 250x Ridden Through Hydrilla (Seaweed) - The Aftermath - Please Give Your Thought
    By boxlaxman in forum Kawasaki PWC Performance (4-stroke)
    Replies: 5
    Last Post: 08-12-2010, 12:40 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •