Results 1 to 2 of 2
  1. #1
    green08's Avatar
    Join Date
    Jul 2009
    Location
    KC/ ozarks
    Posts
    33

    01/05 gprxp same rpm lost 5-7 mph?

    gprxp 8150rpms was running 87+ gps
    now running 83.5 if im lucky at 8150 rpms
    i was running the 1200 single grate when i lost the speed
    put on the ss800 grate and it didnt make a difference maybe couple tenths..
    skat 12 vein dynafly prop look to be in good shape cant see anything wrong..
    any ideas?
    pump or shoes seals???


  2. #2
    westy's Avatar
    Join Date
    May 2007
    Location
    Australia (Bundaberg)
    Posts
    1,132
    +1
    45
    check your pump tunnel and make sure the pump shoe isnt hanging down...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FS 01/05 GPRXP - Needs some work
    By drewkeen in forum Conversion Skis Classifieds
    Replies: 6
    Last Post: 08-25-2016, 03:20 PM
  2. FS F/s gprxp 01/05
    By green08 in forum Conversion Skis Classifieds
    Replies: 13
    Last Post: 12-13-2011, 09:28 PM
  3. any suggestions? same rpm lost 5-7 mph from almost 90 to low 80s same rpm
    By green08 in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 08-30-2010, 08:40 PM
  4. Is the 05 red same as 06?
    By red rider in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 05-10-2008, 10:08 PM
  5. Engine Problem, top speed RPM lost
    By BlackHawk in forum 4-Tec Performance
    Replies: 11
    Last Post: 08-30-2006, 01:34 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •