Results 1 to 10 of 10
  1. #1
    rockonup's Avatar
    Join Date
    Sep 2009
    Location
    Shelby Twp Michigan
    Posts
    153
    +1
    2

    Question Advice needed and what eles could be wrong.

    A few weeks ago one of my RXP X's took on a lot of water. It was 3/4 under water to say cuz someone towed it in backwards. I drained the water on the trailer by putting it on the ramp and pulling the plugs and did not start it or try to. I took it to Dee's Marina in Clinton Twp Michigan right away, where I bought the machines brand new. I told them what happen and so fourth. I also did the regular maintence to get both super chargers rebuilt at 100 hours. Which cost $580 to rebuild. I got my machines back Thursday so I was excited to get both back on the water after they had them for almost 2 weeks. The one machine ran fine and had no problems. Before I put the other one in I wanted to see if it could start, so i tried starting it said the 12v battery was low so I hooked my 12v 2 amp slow charger up to it, charged fully in about 3 or 4 hours. Put it in the water got about 200 feet from the dock and had one loud beep that wouldnt stop with oil light. I also had a code flash up P1690 which means trim VTS i notice my trim was not working properly would come down after holding it for 5 seconds or longer and only go to level then it would go back up and not come back down unless i took the key out and put it back in. This is where I became upset thinking the dealer would of checked the whole machine over for things like this after taking on water, but wait I pulled the dip stick and notice the stick had looked like it was sitting in a bowl of ceral. The dealer had charge me a total of $1,489 to get oil changed in both and the one checked out to be in working order. I told the dealer I did not care what it cost to get it running order the parts you need to get it back in tip top shape. The had 2 full weeks to do this, yet I get a machine back that is not running. So I took it to another dealer K & W in Utica Michigan where they had done some prop and wear ring work when i sucked up a rock last season. And had no problems with anything. So I need some advice on what I should also beware of and what I should check or have them check or ask them what to look for or at incase we missed anything. I just want to have both working for this weekend


  2. #2
    Banned User
    Join Date
    Sep 2009
    Location
    Aussie Land
    Posts
    804
    +1
    21
    Getting a VTS code or something similar can be indicative of a dead battery...

    Look, that oil will have to get changed and changed again, maybe 5-6 times to get it anywhere near 'good enough'... I'm a bit worried it has been so long since drowning and its still got water in the engine, I'm not too sure what could be happening in the motor but you need to get that motor running after 5-6 oil changes and 1 oil filter change and boil out the remaining water....
    (Ask them how many oil changes they did in that service)

    To get it running, I would swap batteries with your other ski and at least rule out a faulty battery...
    Have a looksee what happens when you do that.... Batteries are funny things, especially if emersed in salt water for an extended period to say the least!


    If it was me: I'd check to make sure it had at least 3 oil changes, swap the batteries, and get that motor running and boil out the liquid ASAP.

  3. #3
    Eric Ocman's Avatar
    Join Date
    Aug 2008
    Location
    Cataula, Georgia, United States
    Posts
    4,700
    +1
    77
    If your oil looks like cereal you could have some serious issues bro. Get that taken care of asap!

  4. #4
    Banned User
    Join Date
    Sep 2009
    Location
    Aussie Land
    Posts
    804
    +1
    21
    I think a key bit of information might also be: Why was it towed in the first place?!

    By cereal I'm guessing he's saying 'white' or milky, so that's water in the oil by my guess...

  5. #5
    rockonup's Avatar
    Join Date
    Sep 2009
    Location
    Shelby Twp Michigan
    Posts
    153
    +1
    2

    Angry

    It was towed because it started to storm n the people didnt know the correct way of towing it they towed it in backwards. You would think have a 45 foot yacht you would have boating expertise. Guess not. I took it to the dealer ASAP next day and they said they changed the oil 4 times, cereal yes i do mean milky water. Thanks for the tip on the battery for VTS. But doesnt explain why the dealer didnt keep changing the oil or boil out the rest or properly take the time to check everything over after running it and letting it sit. What the F*** did they do for 2 weeks is my question Again this was a legit SEADOO dealer.

  6. #6
    rockonup's Avatar
    Join Date
    Sep 2009
    Location
    Shelby Twp Michigan
    Posts
    153
    +1
    2
    Update on the Ski K & W called me back and said they got the VTS working just need to be dryed out and re greased and works fine. They were saving me $390 by just buying the switch and making a few wire cuts to solder it back together reall nice so it be only $70.00 but they called back saying they got it to work but I do need a oil pressure switch which is only $28.00 so far so good anyone in the Macomb area I recommend going to K & W they are very nice and never guide you in the wrong direction sure they could said they need the VTS switch and charged me the $70.00 anyways and I prob would of never known. But being an honest dealer they are it was nice of them to call and let me know.

  7. #7
    O'Connell-Ireland's Avatar
    Join Date
    Aug 2010
    Location
    Limerick, Ireland. Sea riding Kilkee, Co. Clare... masssive!!
    Posts
    37
    Bad buzz on ski getting flooded... Was it in sea water? Think you might have elec probs at later date if was and let sit for couple weeks, have seen pins etc corrode over time if not washed properly, which is hard to do.. Best of luck

  8. #8
    formerly Gold06RXP Turbo Nick's Avatar
    Join Date
    May 2007
    Location
    Dayton, OH
    Posts
    2,095
    +1
    97
    Hes fresh water on the great lakes. But water in engine is bad no matter what
    Quote Originally Posted by O'Connell-Ireland View Post
    Bad buzz on ski getting flooded... Was it in sea water? Think you might have elec probs at later date if was and let sit for couple weeks, have seen pins etc corrode over time if not washed properly, which is hard to do.. Best of luck

  9. #9
    rockonup's Avatar
    Join Date
    Sep 2009
    Location
    Shelby Twp Michigan
    Posts
    153
    +1
    2
    Got the ski back from K&W starts right up on the trailer they got the VTS working just needed and oil pressure switch and I gotta rinse the hull out from the boil out. They said take some soapy water ride around real quick then put it on the trailer and drain it. Cuz in the parking lot i pulled the drain plugs out and some milky oil was coming out from both sides.

  10. #10
    rockonup's Avatar
    Join Date
    Sep 2009
    Location
    Shelby Twp Michigan
    Posts
    153
    +1
    2
    I figured I will update this when I can now that I'm having another problem from dees. Costing me about $4,000 due to the supercharger rebuild they did during this time. Stay posted

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need help, advice, on what could be wrong ???
    By Boucheaux in forum 4-Tec Performance
    Replies: 11
    Last Post: 09-02-2016, 05:17 AM
  2. Lots of $ into mods and only 67.3mph what could be wrong ?
    By Ultra250xryder in forum Kawasaki PWC Performance (4-stroke)
    Replies: 24
    Last Post: 10-01-2007, 11:12 AM
  3. Advice needed on what to use on Ultra Black Parts
    By tomgtv in forum Kawasaki PWC Performance (4-stroke)
    Replies: 15
    Last Post: 07-22-2007, 12:59 PM
  4. What could be wrong...water ingestion?
    By rx4pain in forum 4-Tec Performance
    Replies: 7
    Last Post: 06-26-2005, 11:12 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •