Results 1 to 2 of 2
  1. #1

    sl900 bottom grate missing, will this cause low rpm problems?

    I was inspecting the bottom of my hull, and noticed that the bottom grate is missing. I have posted about not always being able to reach high rpms, will this cause my problem? Ski gets stuck around 45mph, and all the sudden will kick in and blast to full speed.

  2. #2
    seaobin's Avatar
    Join Date
    Jun 2007
    Raleigh, North Carolina, United States
    I lost the grate on my 750SS Kawi and it acted the same way. Also felt like the back end was sliding around a lot more as well

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 06 RXP Low RPM's, Supercharger, Low voltage...
    By dcvet in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 06-16-2008, 09:54 AM
  2. Sl900 Low Rpm/mph
    By twinstack1 in forum Polaris Open Discussion
    Replies: 7
    Last Post: 07-05-2007, 08:39 AM
  3. Missing RPM's?
    By ARNYGOLLOTT3 in forum 4-Tec Performance
    Replies: 12
    Last Post: 06-30-2007, 01:41 PM
  4. Down Low,,Bottom
    By HOSS in forum Open Discussion
    Replies: 17
    Last Post: 09-21-2006, 07:30 PM
  5. Missing RPM???
    By TxTele in forum Yamaha PWC Performance (2-stroke)
    Replies: 10
    Last Post: 04-18-2006, 10:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts