Results 1 to 6 of 6
  1. #1
    canadianRxtX's Avatar
    Join Date
    Mar 2009
    Location
    Southern Ontario
    Posts
    364

    Oil Pump cover wear / damage ?

    Didnt see a thread on this.. in trying to uncover the problem with my X found this: what would cause the oil pump cover to have deep scratches in it? Also the oil pressure bypass (i think is what it is ) valve on a spring is pretty badly worn.. Wtf? Oil and filter are clean.. SCer is fine. Almost looked like the oil pump impeller was touching down on the cover. I change the oil around 10 hour mark usually. WTF


  2. #2
    R88ory RXP's Avatar
    Join Date
    Feb 2008
    Location
    Kent, England
    Posts
    2,737
    +1
    46
    Quote Originally Posted by canadianRxtX View Post
    Didnt see a thread on this.. in trying to uncover the problem with my X found this: what would cause the oil pump cover to have deep scratches in it? Also the oil pressure bypass (i think is what it is ) valve on a spring is pretty badly worn.. Wtf? Oil and filter are clean.. SCer is fine. Almost looked like the oil pump impeller was touching down on the cover. I change the oil around 10 hour mark usually. WTF
    Have you had the ski from new??

    Sounds like SC washer damage.

    R88

  3. #3
    canadianRxtX's Avatar
    Join Date
    Mar 2009
    Location
    Southern Ontario
    Posts
    364
    Quote Originally Posted by R88ory RXP View Post
    Have you had the ski from new??

    Sounds like SC washer damage.

    R88
    Yup owned it since new.. it is 08 so it had metal washers to begin with, changed to Riva's. never had washer problem or failure. It appears like it just started happening. The scratches in the housing were pretty bad but definitely not were not due to a long term grinding problem.

  4. #4
    canadianRxtX's Avatar
    Join Date
    Mar 2009
    Location
    Southern Ontario
    Posts
    364
    i should be more clear, it is not the oil pump housing, but the cover piece. I tried to link it to the BRP manual so you can see. but it wont save the link properly.

  5. #5
    Water4fire's Avatar
    Join Date
    May 2005
    Location
    New Braunfels TX.
    Posts
    10,062
    +1
    790
    This normal. I have found slight ecthing, scratching on the covers on most 4tecs I open up.

  6. #6
    canadianRxtX's Avatar
    Join Date
    Mar 2009
    Location
    Southern Ontario
    Posts
    364
    Ok thanks for that info! so I def. have not found my problem yet! Dammit

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Oil pump cover and pto, Need Advise
    By BEECHFRONT in forum 4-Tec Performance
    Replies: 4
    Last Post: 09-26-2014, 12:09 PM
  2. Can oil pump covers be resurfaced??
    By C14RKS in forum 4-Tec Performance
    Replies: 1
    Last Post: 07-29-2014, 10:54 AM
  3. oil pump cover??
    By RocketmanRod in forum 4-Tec Performance
    Replies: 7
    Last Post: 03-19-2013, 02:06 PM
  4. WTB RXP/RXP Oil Pump Cover part # 420811590
    By caliburst in forum Sea Doo Classifieds
    Replies: 1
    Last Post: 06-30-2010, 03:52 PM
  5. WTB Oil pump cover for PTO pump!
    By Water4fire in forum Sea Doo Classifieds
    Replies: 8
    Last Post: 12-05-2009, 05:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •