Page 1 of 2 1 2 LastLast
Results 1 to 10 of 16
  1. #1

    Join Date
    Apr 2005
    Location
    Upstate NY
    Posts
    37

    Wear ring carnage

    It was all fun and games until the wear ring blew up! I was in a tight turn at WOT and out of the blue I lose a couple thousand RPM and cant even hit 40mph top end. I thought I had blown a piston until I pulled the ski out of the water and inspected the jet pump. This is a new WSM wear ring with about 10 hours on it on my 96 XP. So much for quality.

    I upgraded to a wear ring w/ stainless insert and while I have the pump apart its getting new bearings and seals. I should have my holeshot back pretty soon!

    Shredded Remains:





    New SS ring with XO prop:


    Enjoy!


  2. #2
    Newbie
    Join Date
    Aug 2008
    Location
    NJ
    Posts
    8
    Oh boy, I'm using those same WSM "oem type" wear rings on my challenger 1800. I wonder if something got in there and under the rubber-ish coating to delaminate it which in turn cause the massive carnage

    Glad to see it was easily repairable instead of the piston!

  3. #3

    Join Date
    Apr 2005
    Location
    Upstate NY
    Posts
    37
    Not sure what caused it, I didnt suck anything up. About a week ago, a few days after I installed this wear ring, I noticed a small 3-4mm piece had pulled out from the middle (looked like it had been sucked out). The impeller wasnt touching the ring in any position and I try to be careful around shore, so I dont think it was sand. Could have been defective. We'll see what happens with the SS ring. Its still WSM, but the clearance is much tighter and the build quality appears to be better.

  4. #4
    Mtuned's Avatar
    Join Date
    Aug 2010
    Location
    Orlando FL
    Posts
    724
    Is your motor aligned properly?

  5. #5
    flyin' the friendly skies airbornexp's Avatar
    Join Date
    Aug 2007
    Location
    Mahomet, Il. USA
    Posts
    6,004
    +1
    163
    I dont think that a motor alignment would cause that but I would think that a failed pump bearing would

  6. #6

    Join Date
    Apr 2005
    Location
    Upstate NY
    Posts
    37
    Yep, I think Airborne's got it. The motor is aligned and mounts are good.

    When I pulled the pump bearings, I noticed a few of the rollers just fell out of the thrust bearing. Take a look:



    New parts on the way!

  7. #7

    Join Date
    Aug 2010
    Location
    Akron, Ohio
    Posts
    30
    Where do you find those SS wear rings? Are they better than a factory replacement type, I need to replace mine this week. Thanks

  8. #8
    Congrats ! That's the best I've ever seen in over 16 years

  9. #9
    Work Harder, Millions on Wellfare Depend On Us! ultramaxracing05's Avatar
    Join Date
    Aug 2009
    Location
    Beaumont, Texas
    Posts
    2,999
    +1
    123
    I never had a problem with the wsm wear rings, I installed many, they will dry rot over the years but thats the same as the OEM. maybe the thrust bearing was on its way out, when you installed the new wear ring.

    Do remember that with stainless wear ring. If you get something caught in there, the wear ring will not take the hit, your impeller will become damaged, dont let any newbie ride your ski specially with a ss wear ring.

  10. #10
    flyin' the friendly skies airbornexp's Avatar
    Join Date
    Aug 2007
    Location
    Mahomet, Il. USA
    Posts
    6,004
    +1
    163
    Quote Originally Posted by David_HX_RXP View Post
    Congrats ! That's the best I've ever seen in over 16 years

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. TIP - Bar Extensions and Wear Ring Info
    By MikeTrin in forum Sea Doo How To & FAQs
    Replies: 7
    Last Post: 06-19-2007, 03:05 PM
  2. stainless steel wear ring
    By shortee in forum 4-Tec Performance
    Replies: 12
    Last Post: 06-18-2005, 09:36 PM
  3. wear ring damage
    By INDY27 in forum 4-Tec Performance
    Replies: 18
    Last Post: 05-25-2005, 08:41 PM
  4. wear ring removal
    By watermedic in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 05-18-2005, 09:12 AM
  5. wear ring
    By nitro rxp in forum 4-Tec Performance
    Replies: 16
    Last Post: 05-12-2005, 05:58 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •