Results 1 to 2 of 2
  1. #1

    1997 sltx problems

    hi all
    the other day while pulling a tube ski ran over the pull rope(friend was driving). the engine quite on its own(not from friend relizing he ran over rope). was able to get ski out of water and free rope.ski was put away that day. next day out on water ski was acting up would get up to full rpm but over alittle bit of riding the rpm's would decrease(not the limiter decrease) instead of 6500 rpm comes down to 6000 sometimes diping down to 5500. I had a problem with bad gas earlier in summer so i thought might just be gas i cleaned out fuel/water seperater(was clean but cleaned anyway).still ran same.put some carb cleaner in gas and ran alittle seamed ok. i didnt ride that much that day next time on water noticed problem still there. i ran it hard to see if it would clear it self. ran it hard for maybe 10 mins and i got the blinking lite saying hot. limiter engaged and i slowly got it back to dock by the time i got back to dock the light went off on its own. so as not to damage any further i pulled ski out of water.
    wanted to know where to go to troubleshoot.
    i havent checked compression yet(was good in beginning of season)i have to get tester from friend
    what else can i check?
    thanks all in advance for the help


  2. #2
    casey67's Avatar
    Join Date
    Sep 2006
    Location
    Lemont,IL
    Posts
    2,571
    +1
    35
    Make sure none of the rope is still wrapped around the shaft-impeller-stator.
    The cooling system screen is at the rear of the jet pump,make sure that is clear.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Polaris 1997 SLTX Charging problem
    By KRR in forum Polaris Open Discussion
    Replies: 11
    Last Post: 06-28-2014, 09:46 AM
  2. 1997 Polaris SLTX Problems
    By taco157 in forum Polaris Open Discussion
    Replies: 9
    Last Post: 07-07-2012, 11:34 AM
  3. Replies: 6
    Last Post: 05-16-2012, 03:15 PM
  4. 1997 sltx problems
    By beans in forum Polaris PWC Performance
    Replies: 0
    Last Post: 09-02-2010, 09:13 AM
  5. 69.3 Mph 1997 Sltx
    By 800AMSOIL4U in forum Polaris PWC Performance
    Replies: 28
    Last Post: 11-01-2006, 04:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •